Problem with robot_pose_ekf [closed]

asked 2013-03-28 07:03:19 -0500

updated 2013-04-02 07:03:54 -0500


I am trying to get the tf between /odom and /base_footprint using robot_pose_ekf, but for some reason it is not working. I am using a slightly modified version of the launch file provided.

When I run view_frames however /odom and /base_link still aren't attached. I'd appreciate it if someone could tell me what I am doing wrong.


Edit: Going to try to put in the code. Let's see if it works this time.

Edit 2: So I figured out that my remap from odom to pr__base_odometry/odom was wrong and changed it to remap from odom to encoder, since that is what the odometry data is called for the husky. Unfortunately, that did not fix my problem. I have changed the code below to show what it looks like now. I have also attached the image I get from view_frames.


  <node pkg="robot_pose_ekf" type="robot_pose_ekf" name="robot_pose_ekf" >
    <param name="output_frame" value="odom"/>
    <param name="freq" value="30.0"/>
    <param name="sensor_timeout" value="1.0"/>
    <param name="odom_used" value="true"/>
    <param name="imu_used" value="false"/>
    <param name="vo_used" value="false"/>
    <param name="debug" value="false"/>
    <param name="self_diagnose" value="false"/>
    <param name="pub_odometry" value="true"/>
    <remap from="odom" to="encoder" />

Edit 3: So I may have discovered what is going on. When I run rostopic hz /robot_pose_ekf/odom I get no response, indicating that there is no outpout. When I run rostopic hz /encoder I also get no response, indicating that the husky is not sending out the odometry data. I have started a new question regarding that issue, but I will leave this question open until I am certain that this is the problem.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Icehawk101
close date 2013-04-02 11:05:33


How have you modified the launch files? Has robot_pose_ekf started up (it should output a message saying so if it did). The output_frame parameter in the launch file should be set to what you need, which in your case is 'odom'?

pmukherj gravatar image pmukherj  ( 2013-03-28 07:54:29 -0500 )edit

As you can see the output frame is set to odom. When I run the file it gives me a summary with parameters and nodes, would that be the message you are talking about?

Icehawk101 gravatar image Icehawk101  ( 2013-03-28 10:03:06 -0500 )edit