Ask Your Question
1

Hokuyo URG-04LX-UG01 Measuring area

asked 2013-03-24 23:43:13 -0500

CarolineQ gravatar image

updated 2014-01-28 17:15:53 -0500

ngrennan gravatar image

I am tying to use the Hokuyo node to get scan data from the Hokuyo laser URG-04LX-UG01. When I visualized the laser scan in rviz, I only have a measuring area from -90° to 90°, and the measuring area of the laser should be 240°.

So I tried to change the parameters min_angle and max_angle of the hokuyo node but the maximum measuring area that I get is from -120° to +90°. Do you have any idea why I can't get data between 90° and 120° ?

Thanks for help, Caroline

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
3

answered 2013-03-24 23:59:34 -0500

Ben_S gravatar image

What are the values you are setting as min- and max-angle? And are you setting them through dynamic reconfigure or in the launch file? Please provide some more information and the console output of the hokuyo_node.

Try setting them to some values slightly larger than the actual max-angles. Like -2.1 for min_angle and 2.1 for max_angle. If it is not too far off, the hokuyo_node should automatically set them to the maximum allowed values. (3 would be too much...)

edit flag offensive delete link more

Comments

+1 to this. The default behavior of hokuyo_node is to have min and max angles which are smaller than your scanner's field of view. You can either change the launch file or change them via dynamic reconfigure at runtime.

Gav gravatar image Gav  ( 2013-03-25 02:30:22 -0500 )edit

I put the values you said and it works now. Thanks for help.

CarolineQ gravatar image CarolineQ  ( 2013-03-25 22:54:11 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-03-24 23:43:13 -0500

Seen: 800 times

Last updated: Mar 24 '13