Ask Your Question
0

help with hector_exploration and hector_mapping

asked 2013-03-24 17:31:54 -0600

nikkihohn gravatar image

updated 2013-03-24 17:42:33 -0600

Hi,

I am trying to run hector_exploration_node and hector_mapping.

First, I launch the pointcloud_to_laserscan (I am using a kinect and getting laser scan data from pointcloud_to_laserscan), then I run the launch file for hector mapping, and then I run the launch file for hector_exploration_node. I also have segway drivers running in the background.

After launching hector_ exploration_node, I get this warning: Waiting on transform from /base_link to /map to become available before running costmap, tf error:

After messing with the launch file, I managed to get this warning: Waiting on transform from /base_link to /map to become available before running costmap, tf error: Could not find a connection between '/map' and '/base_link' because they are not part of the same tree.Tf has two or more unconnected trees.

I edited the hector_ugv.launch file and added the following: "node pkg="tf" type="static_transform_publisher" name="base_link_map_broadcaster" args="0 0 0 0 0 0 base_link map 100"

After this, I managed to get rid of the previous error and now it says "Initializing hectorExplorationPlanner" but does not do anything after that.

I have read through the other similar questions but I do not understand the solutions posted. I am also wondering why I did not get a specific tf error in the first place and if the edit that I made to get rid of the tf error is even correct.

Another thing, can I simply install and run hector_exploration_node as it is or do I need to change some configurations? If so, what configurations should I change?

Any help would be sincerely appreciated, thank you!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-03-24 21:34:07 -0600

This sounds like a problem with your tf tree. The error message points at a disconnected tree with no transform between base_link and map, which sounds like the SLAM/localization solution is not setup properly. It would be helpful if you can edit your post with some info about your tf tree (for example output of view_frames as described here).

Also, using hector_mapping with the Kinect likely will not work well, if you only have a Kinect (and hopefully odometry), it is recommended to use slam_gmapping.

edit flag offensive delete link more

Comments

Okay, that makes sense. I ended up using gmapping instead and hector_exploration_node and it seems to be working now. The robot moves faster than I would like it to move but I think I need to mess with config files a bit more. Thanks for all your help!

nikkihohn gravatar imagenikkihohn ( 2013-03-25 13:26:20 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-03-24 17:31:54 -0600

Seen: 730 times

Last updated: Mar 24 '13