Ask Your Question
1

Problem with ros networking

asked 2013-03-12 05:29:49 -0500

agonzamart gravatar image

updated 2014-01-28 17:15:38 -0500

ngrennan gravatar image

I am using a Desktop Pc and a Remote pc on a pioneer base as my Ros fuerte architecture. On this one I ran my roscore and some nodes to interact with the pioneer. The rest nodes I run them on the PC. I am having a problem with the network. When I launch a launch file from ros with the machine tag from the Desktop computer to the laptop on the pioneer.

<machine name="higgs" address="higgs" env-loader="/opt/ros/fuerte/env.sh"/>

as explained here: ros.org/wiki/roslaunch/XML/machine

I get an error:

remote[higgs-0]: failed to launch on higgs: Unable to establish ssh connection to [higgs:22]: No authentication methods available

But I am able to connect each machines using the ssh command bidirectionally. I use the ROS variables ROS_HOSTNAME(name of each machine) ROS_MASTER_URI(higgs_ip). You can rostopic echo from the different machines, or see the rviz on the Desktop computer from the information on the sensor on the pioneer base. But I have to launch the nodes on the laptop directly.

I will appreciate any help.

edit retag flag offensive close merge delete

Comments

Thank you for your help tbh.

I have set the sshkeys correctly, I do not have to enter the password anymore. But I am still experiencing the same error.

remote[higgs-0]: failed to launch on higgs: Unable to establish ssh connection to [higgs:22]: No authentication methods available

Maybe is the fact that I am using different users in each machine?

I have checked .ssh/autorized_keys in higgs (robot laptop, where I want my remote launch to execute)

ssh -rsa blablabla agonzamart@arturo-desktop (my user and computer) ssh -rsa blablabla higgs@higgs (the user I use in the robot laptop) ssh -rsa blablabla root@arturo-desktop (root user from my computer)

I will appreciate any help.

agonzamart gravatar image agonzamart  ( 2013-04-11 03:07:39 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2013-04-01 04:22:32 -0500

tbh gravatar image

When you ssh to higgs, do you usually need to enter a password? If so, then you probably need to set up your sshkeys. Here's a guide on how to do it.

edit flag offensive delete link more

Comments

Thank you for your help tbh.

I have set the sshkeys correctly, I do not have to enter the password anymore. But I am still experiencing the same error.

remote[higgs-0]: failed to launch on higgs: Unable to establish ssh connection to [higgs:22]: No authentication methods available

Maybe is the fact that I am using different users in each machine?

I have checked .ssh/autorized_keys in higgs (robot laptop, where I want my remote launch to execute)

ssh -rsa blablabla agonzamart@arturo-desktop (my user and computer) ssh -rsa blablabla higgs@higgs (the user I use in the robot laptop) ssh -rsa blablabla root@arturo-desktop (root user from my computer)

I will appreciate any help.

agonzamart gravatar image agonzamart  ( 2013-04-11 03:07:22 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-03-12 05:29:49 -0500

Seen: 1,445 times

Last updated: Apr 11 '13