Ask Your Question
1

How to ssh into turtlebot?

asked 2011-08-26 10:08:21 -0500

ParkerGibbons gravatar image

updated 2011-09-23 05:26:49 -0500

kwc gravatar image

I got my computer for my turtlebot today, and I think (and hope!) I got it set up properly. However, while I was going through the tutorials, I encountered a problem with ssh-ing into my turtlebot. I typed "ssh turtlebot@turtlebot" into my terminal, but it says "ssh: Could not resolve hostname turtlebot: Name or service not known". Is there something I need to know about how to ssh into something? Do I need to type something else into the terminal?

-Parker Gibbons

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted
7

answered 2011-08-27 04:15:51 -0500

Ryan gravatar image

The computer that you're SSHing from needs to know what IP 'turtlebot' refers to is. Try finding the IP of the TurtleBot by running ifconfig in a terminal on the TurtleBot. Then, try:

ssh turtlebot@<IP>

If you are setting up a computer from scratch and are not using the official TurtleBot iso, you may also need to install a server for ssh on your TurtleBot:

sudo apt-get install openssh-server
edit flag offensive delete link more

Comments

I was using the official iso, but I did not have an ssh server on the computer. So I may have not downloaded it properly. Can I re load it from the same USB stick?
ParkerGibbons gravatar image ParkerGibbons  ( 2011-08-28 04:55:58 -0500 )edit
Easiest thing to do would be to run the second line from above to install it - it'll be much faster. I had thought the official distribution had the server installed, but it's possible that it's not included by default.
Ryan gravatar image Ryan  ( 2011-08-28 06:15:12 -0500 )edit
I don't believe it's in the ISO at the moment. TIcketed https://kforge.ros.org/turtlebot/trac/ticket/56
tfoote gravatar image tfoote  ( 2011-08-28 14:21:22 -0500 )edit
I just checked it is in the ISO.
tfoote gravatar image tfoote  ( 2011-08-30 15:19:28 -0500 )edit
1

answered 2011-09-21 18:37:29 -0500

Chrimo gravatar image

First of all check the ip-addresses of your systems.

You can do this with the command "ifconfig" at the terminal. With this information, you can reach the remote system very easily.

ssh user@remote-ip-address

edit flag offensive delete link more
1

answered 2011-09-21 17:23:39 -0500

Jonathan gravatar image

You are using your own IP adress as a target (127.0.0.1). You cant be the source and the target at the same time ! The idea of ssh is to log in from an other computer on the network. It should see turtlebot as a local IP, ideally something like 192.168.1.xx

edit flag offensive delete link more
0

answered 2011-08-30 11:31:11 -0500

ParkerGibbons gravatar image

Alright. I installed the ssh server, but it still can not ssh into my robot.

I type "ssh turtlebot@127.0.0.1"

And get back "ssh: connect to host 127.0.0.1 port 22: Connection refused"

What do you think is the problem?

edit flag offensive delete link more

Comments

That's the "local IP" of the laptop. You can only use that IP address if you're physically on the laptop. If you're on a wireless network, type "ifconfig wlan0" to get the proper address
Ryan gravatar image Ryan  ( 2011-08-30 12:18:45 -0500 )edit
1

Type $ifconfig on your turtlebot's terminal.

Near the wlan0 section you will see your turtlebot's inet addr:xxx.xxx.xx.x

Thats the correct address

Panos_Mallioris gravatar image Panos_Mallioris  ( 2019-04-02 03:06:45 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-08-26 10:08:21 -0500

Seen: 3,815 times

Last updated: Sep 21 '11