Ask Your Question
0

ROS over Ad-Hoc

asked 2014-04-14 19:38:06 -0600

lvntbkdmr gravatar image

Hi,

I'm trying to run ros on my local network. (2 machines communicating each other) However, sometimes tf lookuptransform gives me timeout errors. I've read that it is caused of time asynchronization between machines. I tried to synchronize them by using NTP but no luck.. I thought maybe if i don't use my router and connect those machines directly over ad-hoc, i can get better results? Is ad-hoc can be used with ROS? is there any different instructions do i have to follow besides http://wiki.ros.org/ROS/Tutorials/Mul...

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2014-04-14 20:40:17 -0600

Changing the approach for connecting the two machines will not improve time synchronization automatically. NTP already estimates the latency between computers when performing synchronization (see Wikipedia). It´s likely that either time synchronization does not work for some reason (then it will likely not work better using ad-hoc networking), or it works and you get tf lookup errors because you transmit too much data over your wireless link, meaning that some tf data gets dropped.

You can check your time sync as decribed here. If it´s good (a few milliseconds max) then your problem likely is not time synchronization and you should look at decreasing the amount of data you transmit between computers. If it´s bad, it´s recommended to install chrony to perform time sync.

edit flag offensive delete link more

Comments

ok than i will try again by using chrony. I have one more question. In my network i have my laptop and a pandaboard connected over wifi and doing SLAM. Pandaboard supplies base_footprint -> base_stabilized, base_stabilized -> base_link and base_link -> laser frames.

lvntbkdmr gravatar imagelvntbkdmr ( 2014-04-14 21:30:42 -0600 )edit

My laptop does SLAM and generates map -> base_footprint frame. However, when i type rosrun tf tf_echo /map /base_link on my pandaboard. It cannot find map frame, but when i run tf_echo on my laptop, it shows tf data. Why my pandaboard doesn't get map frame ?

lvntbkdmr gravatar imagelvntbkdmr ( 2014-04-14 21:30:49 -0600 )edit

do you think is it related to time sync. or how can i debug the problem? thanks

lvntbkdmr gravatar imagelvntbkdmr ( 2014-04-14 21:30:53 -0600 )edit

Could also be related to a network setup issue. You should try if communication works in both direction by running the talker/listener example you posted in your original question.

Stefan Kohlbrecher gravatar imageStefan Kohlbrecher ( 2014-04-14 22:56:15 -0600 )edit

After setting up a network, is there any chance that it works in one direction ?? one of the machines runs roscore, the other one can connect to that roscore and see its rostopic list. Is there any chance that master(the one running roscore) cannot see its clients ?

lvntbkdmr gravatar imagelvntbkdmr ( 2014-04-14 23:19:07 -0600 )edit

Yes, IIRC there are (bad) configurations where you can see topics, but not receive data from them. For that reason, you should try out communication in both directions.

Stefan Kohlbrecher gravatar imageStefan Kohlbrecher ( 2014-04-14 23:22:10 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-04-14 19:38:06 -0600

Seen: 706 times

Last updated: Apr 14 '14