ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

Missing resource

asked 2013-03-11 11:24:01 -0600

Marija-123 gravatar image

updated 2014-04-20 14:09:24 -0600

ngrennan gravatar image


im trying to install UWSim but when I type rosdep install UWSim it shows me this:

ERROR: Rosdep cannot find all required resources to answer your query Missing resource UWSim

ROS path [0]=/opt/ros/groovy/share/ros

ROS path [1]=/opt/ros/groovy/share

ROS path [2]=/opt/ros/groovy/stacks

I have checked and there is folder opt and every subfolders in it. I have downloaded from wiki a virtual machine with Ubuntu 12.04.1 LTS and ROS Groovy Galapagos pre-installed and tried with that and I still get this error.

Can someone help please...

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2013-03-11 12:27:30 -0600

Miquel Massot gravatar image

updated 2013-03-12 01:51:27 -0600

Follow this for installing instructions. Assumming you have downloaded and added to your workspace the package "underwater_simulator" the command

rosdep install UWSim

should install the required dependencies. The error is "Missing resource UWSim", which means that ROS cannot find UWSim. Test if you can do a "roscd UWSim". If you cannot, then you have to add UWSim to your workspace.

To add this package to your workspace, follow this tutorial. I recommend you to follow all the tutorials.

edit flag offensive delete link more


there is folder "underwater_simulation" in my home directory and it has subfolder "UWSim". "opt" folder with his subfolder "ros" is in File System. I tried to copy "underwater_simulation" to "ros" but it doesnt let me. edit:

Marija-123 gravatar image Marija-123  ( 2013-03-12 01:35:04 -0600 )edit

ros must be installed i have checked in Software Center -> Meta package for desktop-full variant of ROS.

Marija-123 gravatar image Marija-123  ( 2013-03-12 01:48:36 -0600 )edit

answered 2013-03-11 11:47:42 -0600

dornhege gravatar image

rosdep doesn't work this way. rosdep installs dependencies for an installed package, not the package itself.

You are going to have to find the package yourself.

Usually, when release it is available as an ubuntu package via apt-get or when somehow indexed roslocate info might find it.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools


Asked: 2013-03-11 11:24:01 -0600

Seen: 6,458 times

Last updated: Mar 12 '13