Ask Your Question
0

neato node running under groovy

asked 2013-03-09 16:39:43 -0600

DrBot gravatar image

updated 2014-01-28 17:15:36 -0600

ngrennan gravatar image

Has anyone got the ROS Neato node working in Groovy?

I have it working in feurte OK. But in groovy it is giving me a missing driver declaration. I've traced it to the

neato_node/node/neato.py file - here line 44 says neato_driver.neato_driver. And ROS tells me this file cannot be found.

In fuerte the same file, same line asks for just neato_driver (no .neato_driver) I tried changer the .py file to look like the fuerte driver with no success. (The neato.py file has to be edited sometimes to change the USB port name to the correct driver in linux. It defaults to ACM0, but my port is USB0.

I got it via git - set it into a workspace, did the init, rosdep update, etc.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-04-30 12:40:46 -0600

DrBot gravatar image

I have the neato_node running on Unbuntu 11.10 and Groovy using http://ros.org/wiki/neato_node instructions with the added modification of changing USB0 to ACM0 on my laptop.

Unfortunately the same trick does not work using Raspberry Pi and Raspi. Both roslaunch and rosrun die at the same place - line 44 in the neato.py program. I believe that is where the USB port is specified.

rosrun neato_node neato.py _port:=/dev/ttyACM0 doesn't seem to work for either platform for me.

One more clue - a ros_workspace package does work well on either platform.

edit flag offensive delete link more
0

answered 2013-03-09 21:41:21 -0600

fergs gravatar image

Be sure to include the correct setup.bash (from either <workspace>/install or <workspace>/devel) or python will not find neato_driver on the Python path.

Also, you should generally not edit the neato.py file to change port numbers, as there is a parameter for this (~port). Correct port can be set in either a launch file or from the command line depending on how you launch neato.py

edit flag offensive delete link more

Comments

I tried a number of different ways to launch it, but it still comes back no module neato_driver.neato_driver. I've installed the package in a ros workspace run rosws init, the git was neato_robot. rosmake on neato_robot it came back 0 packages rosmake on neato_node - 35 packages.

DrBot gravatar imageDrBot ( 2013-03-10 09:43:51 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-03-09 16:39:43 -0600

Seen: 197 times

Last updated: Apr 30 '13