Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

neato node running under groovy

Has anyone got the ROS Neato node working in Groovy?

I have it working in feurte OK. But in groovy it is giving me a missing driver declaration. I've traced it to the

neato_node/node/neato.py file - here line 44 says neato_driver.neato_driver. And ROS tells me this file cannot be found.

In fuerte the same file, same line asks for just neato_driver (no .neato_driver) I tried changer the .py file to look like the fuerte driver with no success. (The neato.py file has to be edited sometimes to change the USB port name to the correct driver in linux. It defaults to ACM0, but my port is USB0.

I got it via git - set it into a workspace, did the init, rosdep update, etc.

neato node running under groovy

Has anyone got the ROS Neato node working in Groovy?

I have it working in feurte OK. But in groovy it is giving me a missing driver declaration. I've traced it to the

neato_node/node/neato.py file - here line 44 says neato_driver.neato_driver. And ROS tells me this file cannot be found.

In fuerte the same file, same line asks for just neato_driver (no .neato_driver) I tried changer the .py file to look like the fuerte driver with no success. (The neato.py file has to be edited sometimes to change the USB port name to the correct driver in linux. It defaults to ACM0, but my port is USB0.

I got it via git - set it into a workspace, did the init, rosdep update, etc.

neato node running under groovy

Has anyone got the ROS Neato node working in Groovy?

I have it working in feurte OK. But in groovy it is giving me a missing driver declaration. I've traced it to the

neato_node/node/neato.py file - here line 44 says neato_driver.neato_driver. And ROS tells me this file cannot be found.

In fuerte the same file, same line asks for just neato_driver (no .neato_driver) I tried changer the .py file to look like the fuerte driver with no success. (The neato.py file has to be edited sometimes to change the USB port name to the correct driver in linux. It defaults to ACM0, but my port is USB0.

I got it via git - set it into a workspace, did the init, rosdep update, etc.