Ask Your Question
0

Installation of explore package in Groovy (ubuntu 12.10)

asked 2013-03-04 22:14:53 -0500

Victor_ocv2 gravatar image

updated 2013-03-04 22:15:38 -0500

Hello, I have been trying to install the ROS explore package: http://www.ros.org/wiki/explore Unfortunately, there are no binaries available in the form of

apt-get install ros-groovy-*

Therefore, I downloaded it from the svn repository and tried to compile it with rosmake, but I have received the following error:

/opt/ros/rosws/exploration/explore/include/explore/explore_frontier.h:45:34: fatal error: LinearMath/btVector3.h: No such file or directory compilation terminated.

I googled the error, and tried to install several packpages like libbullet-dev liblinear-dev but the problem is still there, thus any help is appreciated. Thank you!

edit retag flag offensive close merge delete

Comments

hello, have you solved the problem? I meet the same problem with you, if you get it through, please help me, thank you.

lewis longman gravatar image lewis longman  ( 2013-12-06 01:22:43 -0500 )edit

4 Answers

Sort by ยป oldest newest most voted
1

answered 2013-03-04 22:22:41 -0500

ahendrix gravatar image

When I looked into the explore package a few months ago, it wasn't compatible with Groovy, and looked like it was unmaintained. In particular, I think the navigation or costmap API has changed, and explore hasn't been updated to match.

I remember it working in Electric, and I don't think I tried it on Fuerte.

edit flag offensive delete link more

Comments

Thank you, that leads me to another question

Victor_ocv2 gravatar image Victor_ocv2  ( 2013-03-04 23:01:29 -0500 )edit

Do you know if the explore package has been updated to be compatible with Groovy now?

nikkihohn gravatar image nikkihohn  ( 2013-03-23 12:52:21 -0500 )edit
0

answered 2013-12-06 02:08:52 -0500

yz gravatar image

updated 2013-12-06 02:11:07 -0500

Hi, could you tell me your ROS version ? Or, firstly, you can try to locate btVector3.h and navfn_ros.h by using :

$ locate navfn_ros.h

for me : /opt/ros/groovy/stacks/navigation/navfn/include/navfn/navfn_ros.h

$ locate btVector3.h

for me : /opt/ros/groovy/include/tf2/LinearMath/btVector3.h

If you can locate these files, then you should add the "include path" to you compilation environment.

edit flag offensive delete link more
0

answered 2013-12-06 00:56:29 -0500

lewis longman gravatar image

When I use the rosmake command in exploration, there are two errors. It tells me "LinearMath/btVector3.h , navfn/navfn_ros.h are not found". Can you help me?

edit flag offensive delete link more
0

answered 2013-11-20 01:57:10 -0500

yz gravatar image

you can just change "LinearMath/btVector3.h" to "tf2/LinearMath/btVector3.h", then do "rosmake exploration" and it should be working.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-03-04 22:14:53 -0500

Seen: 939 times

Last updated: Dec 06 '13