Ask Your Question
0

how to install shadow_hand in ros electric?

asked 2013-01-31 03:46:42 -0600

joseescobar60 gravatar image

updated 2013-02-05 01:36:42 -0600

Hey,

Do you know how to install the shadow hand in the roslectric with ubuntu 11.10, i look for it but the installation is for the fuerte.. any idea?

EDIT

ose@ubuntu:~$ sudo apt-get install ros-fuerte-shadow-robot ros-fuerte-sr-visualization ros-fuerte-sr-teleop
[sudo] password for jose: 
Leyendo listas de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
ros-fuerte-shadow-robot ya está en su versión más reciente.
Tal vez quiera ejecutar «apt-get -f install» para corregirlo:
Los siguientes paquetes tienen dependencias incumplidas:
 ros-fuerte-sr-teleop : Depende de: ros-fuerte-serial-communication (= 0.1.0-s1347132527~oneiric) pero no va a instalarse
 ros-fuerte-sr-visualization : Depende de: ros-fuerte-shadow-robot-ethercat (= 1.1.0-s1356580893~oneiric) pero no va a instalarse
                               Depende de: ros-fuerte-rqt (= 0.1.6-s1355472514~oneiric) pero no va a instalarse
 skype:i386 : Depende de: libasound2:i386 (>= 1.0.23) pero no va a instalarse
              Depende de: libc6:i386 (>= 2.3.6-6~) pero no va a instalarse
              Depende de: libc6:i386 (>= 2.7) pero no va a instalarse
              Depende de: libgcc1:i386 (>= 1:4.1.1) pero no va a instalarse
              Depende de: libqt4-dbus:i386 (>= 4:4.5.3) pero no va a instalarse
              Depende de: libqt4-network:i386 (>= 4:4.8.0) pero no va a instalarse
              Depende de: libqt4-xml:i386 (>= 4:4.5.3) pero no va a instalarse
              Depende de: libqtcore4:i386 (>= 4:4.7.0~beta1) pero no va a instalarse
              Depende de: libqtgui4:i386 (>= 4:4.8.0) pero no va a instalarse
              Depende de: libqtwebkit4:i386 (>= 2.2~2011week36) pero no va a instalarse
              Depende de: libstdc++6:i386 (>= 4.6) pero no va a instalarse
              Depende de: libx11-6:i386 pero no va a instalarse
              Depende de: libxext6:i386 pero no va a instalarse
              Depende de: libxss1:i386 pero no va a instalarse
              Depende de: libxv1:i386 pero no va a instalarse
              Depende de: libssl1.0.0:i386 pero no va a instalarse
              Recomienda: sni-qt:i386 pero no va a instalarse
              Recomienda: libasound2-plugins:i386 pero no va a instalarse
E: Dependencias incumplidas. Intente «apt-get -f install» sin paquetes (o especifique una solución).
edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
2

answered 2013-01-31 19:40:42 -0600

Ugo gravatar image

updated 2013-02-05 02:21:19 -0600

Hi,

If you don't need the latest version of our stacks, you can always use the available electric packages.

If you need something up to date, you'll have to do a source install using rosinstall or rosws. Here is a rosinstall file you can use:

- bzr:
    uri: 'lp:sr-ros-interface'
    local-name: shadow_robot

- bzr:
    uri: 'lp:sr-ros-interface-ethercat'
    local-name: shadow_robot_ethercat

- bzr:
    uri: 'lp:sr-config'
    local-name: sr_config

- bzr:
    uri: 'lp:sr-visualization'
    local-name: sr_visualization

- bzr:
    uri: 'lp:sr-teleop'
    local-name: sr_teleop

Here are a few commands to get you started with this rosinstall file. Copy the code above into a file (let's say /tmp/shadow_robot.rosinstall).

Now let's initialise a ROS workspace (we'll create it in ~/shadow):

mkdir ~/shadow
source /opt/ros/electric/setup.bash
rosws init ~/shadow /opt/ros/electric

You now have an empty workspace, we'll add the rosinstall file to it and fetch the latest revision of the code:

source ~/shadow/setup.bash
rosws merge /tmp/shadow_robot.rosinstall
rosws up

You should now have a workspace containing the different stacks you need. Don't forget to source the correct setup.bash (you should probably add the line below to the ~/.bashrc)

source ~/shadow/setup.bash
edit flag offensive delete link more

Comments

i was trying install an overlay of shadow, but it install ros fuerte, on my opt of course with shadow robot inside. really i don't know how to use bzr, and uri.

monidiaz gravatar imagemonidiaz ( 2013-02-04 03:38:46 -0600 )edit

i need to install the fuerte' s version in a different workspace, i run rosws set.... but i dont know wich web site direction i have to use

joseescobar60 gravatar imagejoseescobar60 ( 2013-02-04 08:24:08 -0600 )edit

To install the fuerte version, you simply need to do: 'sudo apt-get install ros-fuerte-shadow-robot ros-fuerte-sr-visualization ros-fuerte-sr-teleop'

Ugo gravatar imageUgo ( 2013-02-04 20:25:16 -0600 )edit

i try it, but i get a few errors, look in the edit what i gets

joseescobar60 gravatar imagejoseescobar60 ( 2013-02-05 01:36:10 -0600 )edit

From what I understand, your ubuntu install is a bit messed up? Some packages have probably not finished to install or something like this. Did you run the "sudo apt-get install -f" as suggested?

Ugo gravatar imageUgo ( 2013-02-05 01:39:10 -0600 )edit

yes, i did it but i obtain the same error

joseescobar60 gravatar imagejoseescobar60 ( 2013-02-05 01:50:25 -0600 )edit

Yes it's works the installation on this way. Thnks a lot Ugo.

monidiaz gravatar imagemonidiaz ( 2013-02-05 10:18:10 -0600 )edit

excellent. Could you please mark the answer as being correct to close this thread?

Ugo gravatar imageUgo ( 2013-02-05 18:50:49 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-01-31 03:46:42 -0600

Seen: 230 times

Last updated: Feb 05 '13