ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

installing gazebo in a overlay

asked 2013-01-23 03:23:46 -0600

joseescobar60 gravatar image

updated 2013-01-24 04:55:43 -0600

hello, i trying to install a different version of gazebo like a overlay, i create my workspace and run the following lines:

rosws set --svn simulator_gazebo

and the

rosws update

but i obtain this:

virtualtouch@ubuntu:~/fuerte_workspace$ rosws update 
[simulator_gazebo] Installing (version None) to /home/virtualtouch/fuerte_workspace/simulator_gazebo
svn: OPTIONS of '': could not connect to server (
Exception caught during install: Error processing 'simulator_gazebo' : [simulator_gazebo] Checkout of version None into /home/virtualtouch/fuerte_workspace/simulator_gazebo failed.

ERROR in config: Error processing 'simulator_gazebo' : [simulator_gazebo] Checkout of version None into /home/virtualtouch/fuerte_workspace/simulator_gazebo failed.

i dont know if the url adress of the code is wrong, someone could help me?...

im working in ros fuerte with ubuntu 12.04

thank you!!


it works, but when i run:

rosmake simulator_gazebo

i obtain this error:

jose@ubuntu:~/fuerte_workspace$ rosmake simulator_gazebo
[ rosmake ] rosmake starting...                            
[ rosmake ] Packages requested are: ['simulator_gazebo']   
[ rosmake ] Logging to directory /home/jose/.ros/rosmake/rosmake_output-20130123-121016
[ rosmake ] Expanded args ['simulator_gazebo'] to:
['gazebo_plugins', 'gazebo_tools', 'gazebo', 'gazebo_worlds']
[rosmake-0] Starting >>> roslang [ make ]                  
[rosmake-1] Starting >>> urdf_interface [ make ]           
[rosmake-1] Finished <<< urdf_interface ROS_NOBUILD in package urdf_interface
[rosmake-0] Finished <<< roslang  No Makefile in package roslang
[rosmake-1] Starting >>> ivcon [ make ]                    
[rosmake-1] Finished <<< ivcon ROS_NOBUILD in package ivcon
[rosmake-2] Starting >>> common_rosdeps [ make ]           
[rosmake-0] Starting >>> roscpp [ make ]                   
[rosmake-1] Starting >>> colladadom [ make ]               
[rosmake-3] Starting >>> rosconsole [ make ]               
[rosmake-0] Finished <<< roscpp  No Makefile in package roscpp
[rosmake-1] Finished <<< colladadom ROS_NOBUILD in package colladadom
[rosmake-1] Starting >>> roslib [ make ]                   
[rosmake-0] Starting >>> urdf_parser [ make ]              
[rosmake-0] Finished <<< urdf_parser ROS_NOBUILD in package urdf_parser
[rosmake-2] Finished <<< common_rosdeps ROS_NOBUILD in package common_rosdeps
[rosmake-3] Finished <<< rosconsole  No Makefile in package rosconsole
[rosmake-1] Finished <<< roslib  No Makefile in package roslib
[rosmake-2] Starting >>> ogre [ make ]                     
[rosmake-0] Starting >>> collada_parser [ make ]           
[rosmake-0] Finished <<< collada_parser ROS_NOBUILD in package collada_parser
[rosmake-3] Starting >>> resource_retriever [ make ]       
[rosmake-1] Starting >>> angles [ make ]                   
[rosmake-2] Finished <<< ogre ROS_NOBUILD in package ogre  
[rosmake-2] Starting >>> rosbuild [ make ]                 
[rosmake-0] Starting >>> urdf [ make ]                     
[rosmake-3] Finished <<< resource_retriever ROS_NOBUILD in package resource_retriever
[rosmake-2] Finished <<< rosbuild  No Makefile in package rosbuild
[rosmake-0] Finished <<< urdf ROS_NOBUILD in package urdf  
[rosmake-3] Starting >>> opende [ make ]                   
[rosmake-2] Starting >>> rostest [ make ]                  
[rosmake-1] Finished <<< angles ROS_NOBUILD in package angles
[rosmake-1] Starting >>> convex_decomposition [ make ]     
[rosmake-3] Finished <<< opende ROS_NOBUILD in package opende
[rosmake-1] Finished <<< convex_decomposition ROS_NOBUILD in package convex_decomposition
[rosmake-0] Starting >>> srdf [ make ]                     
[rosmake-2] Finished <<< rostest  No Makefile in package rostest
[rosmake-3] Starting >>> collada_urdf [ make ]             
[rosmake-1] Starting >>> parallel_quickstep [ make ]       
[rosmake-1] Finished <<< parallel_quickstep ROS_NOBUILD in package parallel_quickstep
[rosmake-0] Finished <<< srdf ROS_NOBUILD in package srdf  
[rosmake-2] Starting >>> xacro [ make ]                    
[rosmake-1] Starting >>> ogre_tools [ make ]               
[rosmake-3] Finished <<< collada_urdf ROS_NOBUILD in package collada_urdf
[rosmake-1] Finished <<< ogre_tools ROS_NOBUILD in package ogre_tools
[rosmake-0] Starting >>> bullet [ make ]                   
[rosmake-3] Starting >>> geometry_msgs [ make ]            
[rosmake-0] Finished <<< bullet ROS_NOBUILD in package bullet
[rosmake-1] Starting >>> std_srvs [ make ]                 
[rosmake-0] Starting >>> rospy ...
edit retag flag offensive close merge delete


I suspect the output in your edit does not correspond to the original SVN command. That output implies an older version of gazebo that still wants assimp as a ROS package. Can you verify that you are using the same SVN version as you provided in the original question to get the the output provided?

DamienJadeDuff gravatar image DamienJadeDuff  ( 2013-01-23 20:09:41 -0600 )edit

hi, i try to install to many versions, but everyone gets an error, where can i see the SVN version?

joseescobar60 gravatar image joseescobar60  ( 2013-01-24 04:54:22 -0600 )edit

Probably it is best to select one of the tags ( ) as they generally are supposed to correspond to working versions. For other readers, it should be made clear that the poster had an issue with the Fuerte version.

DamienJadeDuff gravatar image DamienJadeDuff  ( 2013-01-25 03:00:26 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2013-01-23 03:37:11 -0600

Your command is fine and it works for me. It looks like was down when you tried. Do you want to try again?

edit flag offensive delete link more

answered 2013-01-23 03:36:17 -0600

KruseT gravatar image

The call seems to be correct, and works for me. So either you were unlucky and can just try again, or you face a network problem. You can also manually run

svn checkout simulator_gazebo

Though that is exactly what wstool does for you.

edit flag offensive delete link more


Do you know how to solve the new problem???

joseescobar60 gravatar image joseescobar60  ( 2013-01-23 05:26:11 -0600 )edit

You need to also download all required dependencies. By the way, maybe check

KruseT gravatar image KruseT  ( 2013-01-23 07:23:43 -0600 )edit

Question Tools


Asked: 2013-01-23 03:23:46 -0600

Seen: 410 times

Last updated: Jan 24 '13