Ask Your Question
0

Unable to access the package in rosws

asked 2013-01-17 13:42:18 -0600

mhariharasudan gravatar image

Hi, Im running on Ubuntu 12.04 and ROS fuerte. I want to calibrate 2 individual cameras as a stereocamera. I created an overlay using rosws in my home folder and then added several packages like uvc_camera, usb_cam, camera_umd and the stack mage_pipleine using the command rosws set <name> --git<uri> After that i resourced the new setup.bash within my workspace.

When i tried to access my package camera_calibration inside the image_pipeline stack using roscd camera_calibration command, it went to the one in my /opt/ros/fuerte/stacks/image_pipeline/camera_calibration instead of the one in my workspace associated with rosws. This problem is only for this package, while i am able to access the other packages in my rosws using roscd.

I also checked the .rosintall file in my local workspace, it listed down all these entries.

Also i tried to install the dependencies of the camera_calibration packages using rosdep install camera_calibration and I am getting the error

ERROR: the following packages/stacks could not have their rosdep keys resolved to system dependencies: camera_calibration: Cannot locate rosdep definition for [sensor_msgs]

Could anyone kindly help me in resolving this. Thanks in advance.

edit retag flag offensive close merge delete

Comments

Thanks for your reply. I did that too but in vain.

Please note that, it is working for all the other packages in the same workspace and does not work only for the camera_calibration.

My ROS_PACKAGE_PATH is set to

/home/hari/fuerte/image_pipeline:/home/hari/fuerte/camera_umd:/home/hari/fuerte/uvc_

mhariharasudan gravatar imagemhariharasudan ( 2013-01-18 03:40:22 -0600 )edit

Not sure why you name your own package with a same name as in the original stacks.. Could you pls try change your package name?

tianb03 gravatar imagetianb03 ( 2013-01-31 21:47:24 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-01-17 22:45:56 -0600

KruseT gravatar image

updated 2013-01-17 22:46:57 -0600

overlaying in fuerte works by searching for packages in the ROS_PACKAGE_PATH. You can investigate it by typing:

echo $ROS_PACKAGE_PATH

The first thing to check when your overlaying package is not found where it should it the ROS_PACKAGE_PATH. The second thing to check is the exact spelling of the name of the package. Often, '-' and '_' are mixed up.

Finally try running

rospack profile

rospack caches locations of packages, and this rebuilds the cache.

The rosdep problem is unrelated and may better be asked in a separate question, or a ticket on the camera_calibration package.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-01-17 13:42:18 -0600

Seen: 278 times

Last updated: Jan 17 '13