Ask Your Question
1

Error building rviz on osx

asked 2013-01-16 21:36:33 -0500

J.M.T. gravatar image

Building rviz on osx i have encountered another problem

[ 61%] 1 warning generated. Building CXX object src/rviz/CMakeFiles/rviz.dir/moc_tool_properties_panel.cxx.o Linking CXX shared library /Users/tatsch/ros_catkin_ws/devel_isolated/rviz/lib/librviz.dylib ld: library not found for -lOgreMain clang: error: linker command failed with exit code 1 (use -v to see invocation) make[2]: * [/Users/tatsch/ros_catkin_ws/devel_isolated/rviz/lib/librviz.dylib] Error 1 make[1]: [src/rviz/CMakeFiles/rviz.dir/all] Error 2 make: ** [all] Error 2

<== Failed to process package 'rviz': KeyboardInterrupt Command failed, exiting.

I found in the ogre forum that this seems to be one of the usual quirks about OS X. The solution could be to use -framework Ogre instead of -lOgreMain, but where would i have to apply that?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-01-17 06:56:46 -0500

WilliamWoodall gravatar image

Make sure you have the latest version of Ogre installed from our repo.

brew remove ogre
brew update
(ros/groovy/ogre should update)
brew install ogre
(or you can do rosdep again)
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-01-16 21:36:33 -0500

Seen: 205 times

Last updated: Jan 17 '13