ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

kinect + ubuntu 12.04 + fuerte

asked 2013-01-08 05:56:00 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I recently installed ubuntu 12.04 and fuerte on it, I am using openni launch package but it's giving me a lot of errors also there is no topic named /camera/depth/points because of which rviz is giving error when i am subscribing to pointCloud2. also it seems that the IR projector of the kinect is not working, I tried this with other kinect but the same problem occurs.

edit retag flag offensive close merge delete



Please read the Support Guidelines and add relevant information to your question: What exact steps (commands) reproduce your problem? What are the exact errors (copy&paste)?

dornhege gravatar image dornhege  ( 2013-01-08 06:14:56 -0600 )edit

Search through previous answers and you will find a lot of information. Are you by any chance using USB3.0 ports? There have been reports of problems with that. You might also have to use a patched version of OpenNI... I needed to do that on my 64 bit Ubuntu 12.04.

georgebrindeiro gravatar image georgebrindeiro  ( 2013-01-08 17:50:48 -0600 )edit

thanks for your reply, I am not using usb3.0 I read those questions and was able to fix those errors but still im not getting /camera/depth/points as one of the topics when I run openni_launch .

akhil gravatar image akhil  ( 2013-01-09 20:25:16 -0600 )edit

Also, you should probably post your console output when you run the openni launch file and when you run lsusb (to see if your hardware is detected by the OS).

georgebrindeiro gravatar image georgebrindeiro  ( 2013-01-10 16:44:50 -0600 )edit

thanks georgebrindeiro it solved my problem ..

akhil gravatar image akhil  ( 2013-01-15 08:21:42 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2013-01-10 16:43:31 -0600

Have you checked out the verified answer to this question? It helped me when I had issues in ROS Fuerte+Ubuntu 12.04 64-bit:

edit flag offensive delete link more

Question Tools


Asked: 2013-01-08 05:56:00 -0600

Seen: 601 times

Last updated: Jan 08 '13