ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

Rosdep experienced an internal error...

asked 2012-12-20 19:50:37 -0500

barrybear gravatar image

Hey all, I seem to be having this problem whenever using rosdep

ERROR: Rosdep experienced an internal error: [Errno 13] Permission denied: '/home/barrybear/.ros/rosdep/sources.cache/index' Please go to the rosdep page [1] and file a bug report with the stack trace below. [1] :

Traceback (most recent call last):
File "/usr/lib/pymodules/python2.7/rosdep2/", line 116, in rosdep_main exit_code = _rosdep_main(args) File "/usr/lib/pymodules/python2.7/rosdep2/", line 257, in _rosdep_main return _package_args_handler(command, parser, options, args) File "/usr/lib/pymodules/python2.7/rosdep2/", line 331, in _package_args_handler lookup = _get_default_RosdepLookup(options) File "/usr/lib/pymodules/python2.7/rosdep2/", line 107, in _get_default_RosdepLookup verbose=options.verbose) File "/usr/lib/pymodules/python2.7/rosdep2/", line 501, in create_default sources = load_cached_sources_list(sources_cache_dir=sources_cache_dir, verbose=verbose) File "/usr/lib/pymodules/python2.7/rosdep2/", line 419, in load_cached_sources_list with open(cache_index, 'r') as f: IOError: [Errno 13] Permission denied: '/home/barrybear/.ros/rosdep/sources.cache/index'

Whenever I try to apply sudo rosdep, I'll obtain this error:

ERROR: Rosdep cannot find all required resources to answer your query Missing resource scan_tools

Can anyone please help me with a fix? Thanks :)

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2012-12-21 08:18:41 -0500

Dirk Thomas gravatar image

updated 2012-12-21 09:56:33 -0500

tfoote gravatar image

First you can verify that all urls listed under /etc/ros/rosdep/sources.list.d/ are valid. For me the file 20-default.list looks like:

# os-specific listings first
yaml osx
yaml gentoo
# generic
gbpdistro fuerte
gbpdistro groovy

Second you might have ran "rosdep update" once with sudo and now the file in your home directory are owner my root and not writable by you anymore. You should remove the folder ~/.ros/rosdep and call "rosdep update" again.

edit flag offensive delete link more


Thats superb! I've got the same listings as the first, and i rm -rf the rosdep dir and call the update again as stated, now it works! ;) Thanks!!

barrybear gravatar image barrybear  ( 2012-12-21 11:54:51 -0500 )edit

answered 2016-05-20 11:01:29 -0500

ElizabethA gravatar image

I know there's already an answer that worked, but for me, the permission denied error were resolved by running "sudo rosdep fix-permissions" from my /home directory. Not sure if being in the /home directory matters, though.

edit flag offensive delete link more


Thanks! This was very useful!

Femer gravatar image Femer  ( 2017-01-19 08:21:26 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools


Asked: 2012-12-20 19:50:37 -0500

Seen: 3,481 times

Last updated: Dec 21 '12