Ask Your Question
0

RGBDSLAM not doing 3D reconsturction (on fuerte)

asked 2012-12-18 20:06:33 -0500

tgaaly gravatar image

updated 2014-01-28 17:14:37 -0500

ngrennan gravatar image

I successfully installed rgbdslam on ROS fuerte. When I launch the kinect+rgbdslam.launch I get the UI. I click on process and the features are detected and the correspondences seem to be working. All looks well but no 3D reconstruction is being shown.

It says at the bottom of the UI: "waiting for motion information" and in the terminal it shows the following:

[ INFO] [1355903732.079881431]: Depth image time: 1355903731 - 878567146
[ INFO] [1355903732.080918784]: RGB   image time: 1355903731 - 913552042
[ WARN] [1355903732.084094819]: Depth and RGB image off more than 1/30sec: 34984896 (nsec)
[ INFO] [1355903732.587797417]: Pause toggled to: false
[ INFO] [1355903732.815951500]: Construction of Node with SURF Features
[ INFO] [1355903737.829001763]: Feature Count of Node:  443
[ WARN] [1355903738.674672363]: Frame id /odom does not exist! Frames (6): Frame /camera_rgb_frame exists with parent /camera_link.
Frame /camera_link exists with parent NO_PARENT.
Frame /camera_depth_optical_frame exists with parent /camera_depth_frame.
Frame /camera_depth_frame exists with parent /camera_link.
Frame /camera_rgb_optical_frame exists with parent /camera_rgb_frame.
 - No odometry available
[ INFO] [1355903738.675202249]: Odometry: Translation 0 0 0
[ INFO] [1355903738.675471277]: Odometry: Rotation 0 0 0 1
[ INFO] [1355903738.693846797]: Ground Truth Transform for First Node: Translation 0 0 0
[ INFO] [1355903738.695485904]: Ground Truth Transform for First Node: Rotation 0 0 0 1
[ INFO] [1355903738.773433385]: Built flannIndex (address 0xaa6050e8) for Node 0
[ INFO] [1355903738.904000759]: Construction of Node with SURF Features
[ INFO] [1355903743.774805419]: Feature Count of Node:  456
[ WARN] [1355903744.660199853]: Frame id /odom does not exist! Frames (6): Frame /camera_rgb_frame exists with parent /camera_link.
Frame /camera_link exists with parent NO_PARENT.
Frame /camera_depth_optical_frame exists with parent /camera_depth_frame.
Frame /camera_depth_frame exists with parent /camera_link.
Frame /camera_rgb_optical_frame exists with parent /camera_rgb_frame.
 - No odometry available
[ INFO] [1355903744.662045199]: Odometry: Translation 0 0 0
[ INFO] [1355903744.662473325]: Odometry: Rotation 0 0 0 1
[ INFO] [1355903744.668235792]: Odometry Delta: Translation 0 0 0
[ INFO] [1355903744.668508592]: Odometry Delta: Rotation 0 0 0 1
[ WARN] [1355903744.668768122]: No Valid Odometry, using identity
[ INFO] [1355903744.668973525]: Comparing new node (1) with previous node 0
[ INFO] [1355903744.731947735]: Feature Matches between Nodes   1 ( 200 features) and   0 ( 200 features) in segment 1/1 (features 0 to 200 of first node):  161. Percentage: 80.500000%, Avg NN Ratio: 0.297273
[ INFO] [1355903744.732694688]: count_matrix(  2,   1) =   161;
[ INFO] [1355903744.733212840]: dista_matrix(  2,   1) =  0.191996;
[ INFO] [1355903744.773284974]: 31 good iterations (from 1000), inlier pct 95, inlier cnt: 154, error: 67.58 cm
[ INFO] [1355903744.774400688]: RANSAC found a valid transformation with 154 inliers matches with average ratio 0.171038
[ INFO] [1355903744.775239970]: Returning Valid Edge
[ INFO] [1355903744.776239537]: Rotation: 0.00, Distance:  0.000m
[ WARN] [1355903744.777023925]: Transformation not relevant. Did not add as Node
[ INFO] [1355903744.777894357]: World->Base: Translation 1.249e-18 0 1.249e-18
[ INFO] [1355903744.778470129]: World->Base: Rotation 0 0 0 1
[ INFO] [1355903744.869838314]: Construction of Node with SURF Features
[ INFO] [1355903750.519140991]: Feature Count of Node:  433
[ WARN] [1355903751.387779597]: Frame id /odom does not exist! Frames (7): Frame /camera_rgb_frame exists with parent /camera_link.
Frame /camera_link exists ...
(more)
edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
1

answered 2013-01-15 22:34:59 -0500

This is caused by the voxelfilter setting. I've removed it from the default launchfile now, so either update your repository, remove it manually from the launch file or use the launchfiles suggested by kk49

edit flag offensive delete link more
0

answered 2012-12-24 17:19:43 -0500

kk49 gravatar image

updated 2012-12-24 17:21:20 -0500

I think this is a settings issue. If I use the launch script in rgbdslam it does the same for me. But if you launch the openni launcher first, then rgbdslam seperately it works.

roslaunch openni_launch openni.launch 
rosrun rgbdslam rgbdslam

(I am also using the ASUS xtion)

edit flag offensive delete link more
0

answered 2012-12-22 16:22:34 -0500

autorover gravatar image

Most likely you are not using a robot to give rgbdslam the odometry it requires. The way SLAM works, it need some control movement which is given by the odometry. You might be able to get a visual odometry package working and link the odometry to rgbdslam if you don't have a bot, or if you do have a bot with odometry readings, they don't appear to be linked to rgbdslam (try looking at rxgraph if that's the case).

edit flag offensive delete link more

Comments

While this is true for many slam systems, rgbdslam does not need odometry.

Felix Endres gravatar imageFelix Endres ( 2013-01-15 22:28:20 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-12-18 20:06:33 -0500

Seen: 709 times

Last updated: Jan 15 '13