ROS Resources: Documentation | Support | Discussion Forum | Service Status | Q&A answers.ros.org
Ask Your Question
1

ROS rgbdslam fuerte support???

asked 2012-07-28 04:58:08 -0500

gpsinghsandhu gravatar image

updated 2014-01-28 17:13:10 -0500

ngrennan gravatar image

I want to know when will there be support for rgbdslam in fuerte. I tried to tinker with the electric supported version to make it run in fuerte but could not get it to work. If someone has found a way around please let me know.

The errors are listed below:

  • rosdep was nable to find eigen(resolved),gl2ps,qt4,libglew,libdevil.
  • src files in g2o do not seem to automatically resolve header files( I had to change many paths to make these error go)
edit retag flag offensive close merge delete

Comments

exactly what problem do you have while running it? Not able to built the package successfully

Sudhan gravatar imageSudhan ( 2012-07-31 05:43:54 -0500 )edit

check below

Sudhan gravatar imageSudhan ( 2012-08-01 03:31:10 -0500 )edit

3 Answers

Sort by ┬╗ oldest newest most voted
2

answered 2012-07-31 21:30:40 -0500

Sudhan gravatar image

updated 2012-09-16 22:13:47 -0500

follow this:

  1. 1st built ros package g2o in the proper ros package path. don't make any change in paths. Nothing you have to edit in g2o.

  2. next edit manifest.xml in rgbdslam package. delete the line '<depend package="eigen"/>' and add the following

<rosdep name="eigen"/>

then you can find something similar to loop starting and ending with <export>. within that add the following line without editing other lines:

<cpp cflags="&lt;code&gt;pkg-config --cflags eigen3&lt;/code&gt; -I${prefix}/include &lt;code&gt;rosboost-cfg --cflags&lt;/code&gt;" lflags="-Wl,-rpath,${prefix}/lib -L${prefix}/lib -lplanning_models"/>

3.then install qt4. simply, use ubuntu software centre. In devoloper tools -> IDE. you can find it (most probably in the name qt creator).

4.then

$ sudo apt-get install libglew1.5-dev libdevil-dev libsuitesparse-dev

$ sudo apt-get install libgsl0-dev

5.then do $ rosmake rgbdslam. Incase, if you find any error try it with $ rosmake --pre-clean rgbdslam.

I hope it should work.

edit flag offensive delete link more
0

answered 2012-07-28 06:31:11 -0500

joq gravatar image

Looks like a duplicate of this question.

edit flag offensive delete link more

Comments

Yes u can say that but I failed to find any info abt anyone trying get this supported in fuerte. I also followed this and some other questions but cudnt get rgbdslam to work in fuerte

gpsinghsandhu gravatar imagegpsinghsandhu ( 2012-07-28 06:34:06 -0500 )edit
0

answered 2012-11-27 08:29:36 -0500

Miguel Riem de Oliveira gravatar image

updated 2012-12-04 05:17:53 -0500

I have removed my previous question since it was wrong.

The solution was actually replicated in another thread.

Sorry about that.

Miguel

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-07-28 04:58:08 -0500

Seen: 1,057 times

Last updated: Dec 04 '12