ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

Fuerte ROS install fails Ubuntu 12.04 with unmet dependencies

asked 2012-12-12 07:28:26 -0600

garym gravatar image

$ sudo sh -c 'echo "deb // precise main" > /etc/apt/sources.list.d/ros-latest.list' [sudo] password for gary: $ wget // -O - | sudo apt-key add - --2012-12-12 10:40:05-- // Resolving ( Connecting to (||:80... connected. HTTP request sent, awaiting response... 200 OK Length: 1162 (1.1K) [application/pgp-keys] Saving to: `STDOUT'

100%[======================================>] 1,162 --.-K/s in 0s

2012-12-12 10:40:16 (59.8 MB/s) - written to stdout [1162/1162]

OK $ sudo apt-get update Ign // precise InRelease Get:1 // precise Release.gpg [198 B]
Get:2 // precise Release [3,046 B]
Get:3 // precise/main i386 Packages [84.0 kB]
Ign // quantal InRelease
Ign // quantal-updates InRelease
Ign // quantal InRelease
Ign // quantal-security InRelease
Ign // quantal-backports InRelease
Get:4 // quantal Release.gpg [72 B]
Hit // quantal Release.gpg
Get:5 // quantal-security Release.gpg [933 B] Get:6 // quantal-updates Release.gpg [933 B]
Get:7 // quantal Release [11.9 kB]
Get:8 // quantal-security Release [49.6 kB]
Get:9 // quantal-backports Release.gpg [933 B]
Ign // precise/main Translation-en_US
Ign // precise/main Translation-en
Hit // quantal Release
Get:10 // quantal-updates Release [49.6 kB]
Get:11 // quantal-security/main Sources [20.9 kB]
Get:12 // quantal/main Sources [1,898 B]
Get:13 // quantal-backports Release [49.6 kB]
Get:14 // quantal-security/restricted Sources [14 B]
Get:15 // quantal/main i386 Packages [2,713 B]
Hit // quantal/main Sources
Hit // quantal/restricted Sources
Get:16 // quantal-security/universe Sources [6,763 B] Hit // quantal/universe Sources
Get:17 // quantal-security/multiverse Sources [695 B] Hit // quantal/multiverse Sources
Hit // quantal/main i386 Packages
Get:18 // quantal-security/main i386 Packages [57.0 kB] Hit // quantal/restricted i386 Packages
Hit // quantal/universe i386 Packages
Hit // quantal/multiverse i386 Packages
Get:19 // quantal-security/restricted i386 Packages [14 B] Get:20 // quantal-security/universe i386 Packages [18.2 kB] Hit // quantal/main Translation-en
Get:21 // quantal-security/multiverse i386 Packages [1,394 B] Hit // quantal/multiverse Translation-en
Ign // quantal/main Translation-en_US
Hit // quantal ...


edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted

answered 2012-12-13 02:24:30 -0600

thebyohazard gravatar image

It looks like it's trying to pull from quantal sources and thus can't find precise dependencies. Did you leave off the 'http:' from your commands? It should be

sudo sh -c 'echo "deb precise main" > /etc/apt/sources.list.d/ros-latest.list

You should copy and paste from the tutorial rather than typing it in.

If that doesn't work, maybe try the answer to this question. Good luck!

edit flag offensive delete link more

answered 2012-12-19 15:31:01 -0600

It can be a missed 'http:' as tbh mentioned, but it also seems that the main repository is broken at the moment. I've got similar issue on freshly installed Ubuntu 12.04 64-bit. Somehow apt-get tried to pull dependencies for i386.

Use one of the mirrors listed in the Wiki instead of main repository. It worked for me.

edit flag offensive delete link more

answered 2012-12-24 00:24:42 -0600

maxie gravatar image

I have got the same problem with a fresh and clean 12.04 ubuntu. Does anyone knows something about when the main repository will be fixed? Since I also tried some of the mirrors which probably are synced after Boris fixed his problem. For me those mirrors give the same failing dependencies. I tried it 7 hours after your post and tried it again today.

edit flag offensive delete link more


Please use answers only for answering questions, not for discussion, comments or your own questions. This is not a forum. Please have a look at the support guidelines before posting.

Lorenz gravatar image Lorenz  ( 2012-12-24 00:40:32 -0600 )edit

answered 2012-12-21 04:43:18 -0600

Anusha gravatar image


sudo apt-get clean
sudo apt-get -f install /* fixes the broken repositories */

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools



Asked: 2012-12-12 07:28:26 -0600

Seen: 1,569 times

Last updated: Dec 24 '12