Ask Your Question
0

Network connection stopping ros subscription

asked 2012-11-25 02:15:30 -0500

heyfred gravatar image

updated 2014-01-28 17:14:22 -0500

ngrennan gravatar image

Whilst running the tutorial: http://www.ros.org/wiki/stage/Tutorials/SimulatingOneRobot

I am trying to write a rosjava program that will subscribe to the robots laser data and then publish messages. When I run the program whilst not being connected to a network it runs as expected and prints out a message to show that it is working.

However when I run it whilst connected to a wireless network the program doesn't appear to be receiving any messages and throws the following exceptions:

INFO: Subscriber registered: Subscriber<Topic<TopicIdentifier</base_scan>, TopicDescription<sensor_msgs/LaserScan, 90c7ef2dc6895d81024acba2ac42f369>>>
25-Nov-2012 14:04:37 org.ros.internal.node.topic.UpdatePublisherRunnable run
SEVERE: org.ros.exception.RosRuntimeException: Connection exception: Laptop2012/67.198.168.6:36300
25-Nov-2012 14:04:37 org.ros.internal.node.topic.UpdatePublisherRunnable run
SEVERE: org.ros.exception.RosRuntimeException: Connection exception: Laptop2012/67.198.168.6:36300
25-Nov-2012 14:04:37 org.ros.internal.transport.ConnectionTrackingHandler exceptionCaught
SEVERE: Channel exception: java.net.ConnectException: Connection refused
25-Nov-2012 14:04:37 org.ros.internal.transport.ConnectionTrackingHandler exceptionCaught
SEVERE: Channel exception: java.net.ConnectException: Connection refused

Does anyone know how or why this is happening relating to my network connection and if I can fix it.

I am running Fuerte on Ubuntu 10.04 (Lucid Lynx).

Thanks

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-12-11 23:27:46 -0500

Benoit Larochelle gravatar image

I also see a similar behavior. I think that ROS cannot find where the nodes are if there are multiple Domain Name Servers (DNS). In my set-up, I have one on the ROS network, and one from my company, which "appears" only when I connect to the WLAN.

One solution could be to hard-code your computer names and IPs in the /etc/hosts file, which can be annoying to maintain. But give it a try in your setup, who knows!

edit flag offensive delete link more

Comments

That's possible. Please file a bug: http://code.google.com/p/rosjava/issues/list

damonkohler gravatar image damonkohler  ( 2013-01-01 09:24:39 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-11-25 02:15:30 -0500

Seen: 250 times

Last updated: Dec 11 '12