Ask Your Question
1

can not find local path of re_comm package (error in environmental variable ROS_ROOT ) [closed]

asked 2012-11-24 08:11:40 -0600

آمال gravatar image

updated 2012-11-29 07:03:01 -0600

Hi :D,

I try to download a recipe from RoboEarth, but system does not find path to re_comm package !! I do not understand what is the error related to ?!


I run this in a terminal roslaunch re_comm re_comm_knowrob.launch

and this in other one

rosrun rosprolog rosprolog re_comm

then visualisation_canvas(_), planvis_create(_).

then re_download_action_recipe('serve a drink', pr2:'PR2Robot1', Recipe), re_generate_cpl_plan(Recipe, CplPlan),planvis_load(Recipe,_).


amal@amal-HP-G62-Notebook-PC:~$ rosrun rosprolog rosprolog re_comm 
% library(swi_hooks) compiled into pce_swi_hooks 0.00 sec, 2,224 bytes
%     library(error) compiled into error 0.00 sec, 10,220 bytes
%    library(lists) compiled into lists 0.00 sec, 25,320 bytes
%   library(shlib) compiled into shlib 0.00 sec, 37,148 bytes
%   library(option) compiled into swi_option 0.01 sec, 8,468 bytes
%  library(process) compiled into process 0.01 sec, 55,748 bytes
% /opt/ros/fuerte/stacks/knowrob/rosprolog/prolog/init.pl compiled 0.01 sec, 60,268 bytes
%    library(jpl) compiled into jpl 0.02 sec, 173,204 bytes
%        library(sgml) compiled into sgml 0.00 sec, 24,636 bytes
%          library(quintus) compiled into quintus 0.00 sec, 11,676 bytes
%         rewrite compiled into rewrite 0.00 sec, 19,416 bytes
%         library(uri) compiled into uri 0.00 sec, 8,048 bytes
%         library(record) compiled into record 0.00 sec, 19,232 bytes
%        rdf_parser compiled into rdf_parser 0.00 sec, 86,224 bytes
%         library(gensym) compiled into gensym 0.00 sec, 2,580 bytes
%        rdf_triple compiled into rdf_triple 0.00 sec, 21,820 bytes
%       library(rdf) compiled into rdf 0.02 sec, 152,096 bytes
%        library(debug) compiled into prolog_debug 0.00 sec, 12,180 bytes
%        library(assoc) compiled into assoc 0.00 sec, 19,484 bytes
%       library(sgml_write) compiled into sgml_write 0.01 sec, 67,520 bytes
%       library(nb_set) compiled into nb_set 0.00 sec, 3,400 bytes
%        library(utf8) compiled into utf8 0.01 sec, 7,108 bytes
%       library(url) compiled into url 0.01 sec, 63,108 bytes
%       rdf_cache compiled into rdf_cache 0.01 sec, 9,016 bytes
%      library(semweb/rdf_db) compiled into rdf_db 0.06 sec, 393,328 bytes
%     comp_similarity compiled into comp_similarity 0.06 sec, 409,756 bytes
%    /opt/ros/fuerte/stacks/knowrob/ias_prolog_addons/prolog/init.pl compiled 0.07 sec, 410,444 bytes
%     library(broadcast) compiled into broadcast 0.00 sec, 4,156 bytes
%    library(semweb/rdf_edit) compiled into rdf_edit 0.01 sec, 48,484 bytes
%    library(semweb/rdfs) compiled into rdfs 0.00 sec, 14,256 bytes
%    library(semweb/owl) compiled into t20_owl 0.01 sec, 37,936 bytes
%      library(socket) compiled into socket 0.00 sec, 7,036 bytes
%      library(base64) compiled into base64 0.00 sec, 9,640 bytes
%     library(http/http_open.pl) compiled into http_open 0.01 sec, 59,684 bytes
%    library(thea/owl_parser) compiled into owl_parser 0.02 sec, 106,936 bytes
%     library(odbc) compiled into odbc 0.00 sec, 21,616 bytes
%    library(semweb/rdfs_computable) compiled into rdfs_computable 0.01 sec, 58,008 bytes
%   /opt/ros/fuerte/stacks/knowrob/semweb/prolog ...
(more)
edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2015-09-01 00:56:48.337751

Comments

1

What ROS distro are you using? What operating system? What does echo $ROS_ROOT print?

joq gravatar imagejoq ( 2012-11-26 05:11:44 -0600 )edit

I am using fuerte ros in ubuntu 10.04. that is /opt/ros/fuerte/share:/opt/ros/fuerte/stacks:/home/amal/ros for echo $ROS_ROOT

آمال gravatar imageآمال ( 2012-11-26 07:25:56 -0600 )edit

1 Answer

Sort by » oldest newest most voted
2

answered 2012-11-26 08:45:08 -0600

joq gravatar image

updated 2012-11-30 05:44:58 -0600

Your environment looks wrong. It should be more like this:

ROS_ROOT=/opt/ros/fuerte/share/ros
ROS_PACKAGE_PATH=/opt/ros/fuerte/share:/opt/ros/fuerte/stacks:/home/amal/ros

Are you sourcing /opt/ros/fuerte/setup.bash in your shell somewhere?

EDIT: Your ~/.bashrc should probably look more like this:

source /opt/ros/fuerte/setup.bash
export JAVA_HOME=/usr/lib/jvm/default-java 
export PATH=$PATH:$JAVA_HOME/bin 
export ROS_PACKAGE_PATH=$ROS_PACKAGE_PATH:/home/amal/ros

I would not recommend repeating the source line.

EDIT 2: I know nothing about java, but those log4j messages are warnings. You should probably follow that link to http://logging.apache.org/log4j/1.2/faq.html#noconfig, and try to eliminate the warning. But, I doubt that is the root problem.

The more serious error is that some java program is looking for rospack in the wrong place. It should be /opt/ros/fuerte/bin/rospack, not /opt/ros/fuerte/share/ros/bin/rospack, which looks similar to the rospack path for Electric.

Maybe something has not yet been updated to work with Fuerte? This looks like a bug to me.

edit flag offensive delete link more

Comments

That is in bash file, What is Wrong ?!

fi

source /opt/ros/fuerte/setup.bash

source /opt/ros/fuerte/setup.bash

JAVA_HOME=/usr/lib/jvm/default-java export JAVA_HOME PATH=$PATH:$JAVA_HOME/bin export PATH export ROS_PACKAGE_PATH=/opt/ros/fuerte/share:/opt/ros/fuerte/stacks:/home/amal/ros

آمال gravatar imageآمال ( 2012-11-26 09:17:38 -0600 )edit

I do not understand why It must looks as You say, what is the error with me and how I make it looks as You say ?!

Thanks

آمال gravatar imageآمال ( 2012-11-26 15:19:46 -0600 )edit
1

You sourced /opt/ros/fuerte/setup.bash twice. That may or may not work, but is definitely unnecessary. Your other commands are improperly formatted (at least as shown here). Please edit your original question and paste in exactly the last few commands in your .bashrc.

joq gravatar imagejoq ( 2012-11-26 15:28:36 -0600 )edit

You can try replacing them with the examples in my answer.

joq gravatar imagejoq ( 2012-11-26 15:29:24 -0600 )edit

Ok I edit The Q

آمال gravatar imageآمال ( 2012-11-26 15:54:03 -0600 )edit

It still looks mangled. Would you try pasting the four lines from the answer above in place of everything following the fi? After editing .bashrc you must open a new shell or terminal for the changes to take effect.

joq gravatar imagejoq ( 2012-11-27 02:05:09 -0600 )edit

I take ur answer in .bashrc but do no difference ?!!

آمال gravatar imageآمال ( 2012-11-29 06:39:43 -0600 )edit
1

What does env | grep ROS display now?

joq gravatar imagejoq ( 2012-11-29 06:55:46 -0600 )edit

Question Tools

Stats

Asked: 2012-11-24 08:11:40 -0600

Seen: 283 times

Last updated: Nov 30 '12