Ask Your Question
0

gazebo wg_world.launch doesn't show world

asked 2012-11-22 10:02:45 -0600

Hi, I'm running ros fuerte on ubuntu 12.04 in a virtual machine.

I'm trying to run gazebo examples, in this case i want to run this tutorial "3D Willow Garage Map", but i get this error and an empty world. Somebody knows something about this?

gustavo@gustavo-VirtualBox:~$ roslaunch gazebo_worlds wg_world.launch
... logging to /home/gustavo/.ros/log/63666e4c-34e5-11e2-8956-08002725ede9/roslaunch-gustavo-VirtualBox-6173.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server 

SUMMARY
========

PARAMETERS
 * /rosdistro
 * /rosversion
 * /use_sim_time
 * /wg_walls

NODES
  /
    gazebo (gazebo/debug)
    gazebo_gui (gazebo/gui)
    xml2factor_wg_walls (gazebo/spawn_model)

auto-starting new master
Exception AttributeError: AttributeError("'_DummyThread' object has no attribute '_Thread__block'",) in <module 'threading' from '/usr/lib/python2.7/threading.pyc'> ignored
process[master]: started with pid [6189]
ROS_MASTER_URI=

setting /run_id to 63666e4c-34e5-11e2-8956-08002725ede9
Exception AttributeError: AttributeError("'_DummyThread' object has no attribute '_Thread__block'",) in <module 'threading' from '/usr/lib/python2.7/threading.pyc'> ignored
process[rosout-1]: started with pid [6202]
started core service [/rosout]
Exception AttributeError: AttributeError("'_DummyThread' object has no attribute '_Thread__block'",) in <module 'threading' from '/usr/lib/python2.7/threading.pyc'> ignored
process[gazebo-2]: started with pid [6216]
Exception AttributeError: AttributeError("'_DummyThread' object has no attribute '_Thread__block'",) in <module 'threading' from '/usr/lib/python2.7/threading.pyc'> ignored
process[gazebo_gui-3]: started with pid [6222]
GNU gdb (Ubuntu/Linaro 7.4-2012.04-0ubuntu2) 7.4-2012.04
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later 
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
For bug reporting instructions, please see:

Reading symbols from /opt/ros/fuerte/stacks/simulator_gazebo/gazebo/gazebo/bin/gzserver...(no debugging symbols found)...done.
[tcsetpgrp failed in terminal_inferior: Inappropriate ioctl for device]
[tcsetpgrp failed in terminal_inferior: Inappropriate ioctl for device]
[tcsetpgrp failed in terminal_inferior: Inappropriate ioctl for device]
Gazebo multi-robot simulator, version 1.0.2
Copyright (C) 2011 Nate Koenig, John Hsu, Andrew Howard, and contributors.
Released under the Apache 2 License.


Exception AttributeError: AttributeError("'_DummyThread' object has no attribute '_Thread__block'",) in <module 'threading' from '/usr/lib/python2.7/threading.pyc'> ignored
process[xml2factor_wg_walls-4]: started with pid [6234]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
Msg Waiting for master.loading model xml from ros parameter
[INFO] [WallTime: 1353617060.820411] [0.000000] waiting for service /gazebo/spawn_gazebo_model
...[tcsetpgrp failed in terminal_inferior: Inappropriate ioctl for device]
Gazebo multi-robot simulator, version 1.0.2
Copyright (C) 2011 Nate Koenig, John Hsu, Andrew Howard, and contributors.
Released under the Apache 2 License.


[tcsetpgrp failed in terminal_inferior: Inappropriate ioctl for device]
[tcsetpgrp failed in terminal_inferior: Inappropriate ioctl for device]
[tcsetpgrp failed in terminal_inferior: Inappropriate ioctl for device]
[tcsetpgrp failed in terminal_inferior: Inappropriate ioctl for device]
[tcsetpgrp failed in terminal_inferior: Inappropriate ioctl for device]
[tcsetpgrp failed in terminal_inferior: Inappropriate ioctl for device]
[tcsetpgrp failed in terminal_inferior: Inappropriate ioctl ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-11-22 23:28:06 -0600

joseescobar60 gravatar image

you can try launching a empty world of gazebo and later try to open the world in gazebo from insert models.

edit flag offensive delete link more

Comments

Hi, @joseescobar60 I did what you said and i can open the wg world, but I think that this world is imported from share folder in stageros package instead of import it from world folder. I need to open it from there because i have another custom worlds that i need to use.

gustavo.velascoh gravatar imagegustavo.velascoh ( 2012-11-29 01:42:14 -0600 )edit

After inserting models to gazebo (e.g. a woman) I can teleop Turtlebot to collide with the inserted model. But strangely, in rviz the robot cannot sense the model. Somehow the inserted model only exists in gazebo but not in rviz. Do you experience this problem?

Chik gravatar imageChik ( 2013-01-09 12:33:53 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-11-22 10:02:45 -0600

Seen: 1,016 times

Last updated: Nov 22 '12