Ask Your Question
3

Gazebo crashes when spawning a robot with urdf.

asked 2014-05-22 02:19:30 -0600

a_stumpf gravatar image

updated 2014-05-22 02:25:05 -0600

Hello,

I'm looking forward to use ROS Indigo with the fresh released Ubuntu 14.04. Gazebo is starting fine but instantly crashes when spawning a robot via service call:

(indigo) alex@ThinkPad-T440p:~/hector$ rosrun gazebo_ros spawn_model -file `rospack find baxter_description`/urdf/baxter.urdf -urdf -z 1 -model baxter
spawn_model script started
[INFO] [WallTime: 1400760484.921875] [0.000000] Loading model xml from file
[INFO] [WallTime: 1400760484.922486] [0.000000] Waiting for service /gazebo/spawn_urdf_model
[INFO] [WallTime: 1400760484.924802] [0.000000] Calling service /gazebo/spawn_urdf_model
Service call failed: transport error completing service call: unable to receive data from sender, check sender's logs for details

Lets Gazebo crash without any message:

[gazebo-1] process has died [pid 14649, exit code 139, cmd /opt/ros/indigo/lib/gazebo_ros/gzserver worlds/empty.world __name:=gazebo __log:=/home/alex/.ros/log/cdde1b80-e1a0-11e3-ab05-5c514ff707c4/gazebo-1.log].
log file: /home/alex/.ros/log/cdde1b80-e1a0-11e3-ab05-5c514ff707c4/gazebo-1*.log

I've just tested it with Gazebo 2.2.2 (sudo apt-get install ros-indigo-gazebo-ros) using "empty_world" and the Baxter robot urdf (see gazebosim.org /Tutorials/1.9/Using_roslaunch_Files_to_Spawn_Models, sry not enough Karma for links ;)).

Has anybody encountered this issue too?

kind regards, Alex

edit retag flag offensive close merge delete

Comments

It's still a big issue. Hasn't anybody else this issue with Ubuntu 14.04 and indigo?

a_stumpf gravatar imagea_stumpf ( 2014-06-02 07:46:41 -0600 )edit

I have the same problem!

fhurlbrink gravatar imagefhurlbrink ( 2014-06-13 07:22:10 -0600 )edit

I think this problem might have to deal with it being a thinkpad. I have the same problem with Hydro and 12.04 and both Gazebo 1.9 and Gazebo 3

4dahalibut gravatar image4dahalibut ( 2014-07-11 14:38:05 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2014-06-12 16:41:29 -0600

jdlangs gravatar image

The root cause seems to be urdf library incompatibilities. The developers are aware of the issue (https://github.com/ros/rosdistro/issues/4633).

I'm also looking forward to a fix but for now it seems the workaround is to use a source-built version of gazebo. See the June 8, 3am comment from jonbinney on that thread.

edit flag offensive delete link more
2

answered 2014-06-18 03:38:46 -0600

peci1 gravatar image

Maybe it is a solution for another URDF-parsing problem, but you may try adding

# fix for liburdf segfault
export LD_LIBRARY_PATH="/usr/lib/x86_64-linux-gnu/:$LD_LIBRARY_PATH"

to your .bashrc .

Hope it doesn't break anything else in your system :) I'm happy with this solution so far.

edit flag offensive delete link more

Comments

To see whether it is really a URDF parsing issue, you may try `gzsdf print myrobot.urdf` . If it crashes, then liburdf is the responsible one.

peci1 gravatar imagepeci1 ( 2014-06-18 03:39:52 -0600 )edit

Thanks for your suggestion but it didn't work in this case.

a_stumpf gravatar imagea_stumpf ( 2014-06-20 03:55:33 -0600 )edit

This solved the segfault-issue for me. (Indigo on Ubuntu14.04)

Sebastian Kasperski gravatar imageSebastian Kasperski ( 2015-02-13 09:09:58 -0600 )edit

This worked for me with ROS Melodic on Ubuntu 18.04

Horse-man gravatar imageHorse-man ( 2019-08-30 17:48:26 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2014-05-22 02:19:30 -0600

Seen: 2,990 times

Last updated: Jun 18 '14