Ask Your Question
1

Could not find a package configuration file provided by "controller_manager"

asked 2015-08-12 18:03:45 -0600

thumper gravatar image

I am running ROS jade on an Ubuntu 14.04 OS and I am trying to connect the Gazebo simulator to ROS. I have followed the tutorials to connect Gazebo to ROS on the Gazebo website, and now I am trying to download the URDF of the Pioneer 3dx robot (since that is the robot I am using), but I am running into a problem. I have placed the URDF file from a github site into the src directory of my catkin_ws, but whenever I run "catkin_make" I always get this error:

CMake Error at /opt/ros/jade/share/catkin/cmake/catkinConfig.cmake:75 (find_package): Could not find a package configuration file provided by "controller_manager" with any of the following names:

controller_managerConfig.cmake
controller_manager-config.cmake

Add the installation prefix of "controller_manager" to CMAKE_PREFIX_PATH or set "controller_manager_DIR" to a directory containing one of the above files. If "controller_manager" provides a separate development package or SDK, be sure it has been installed. Call Stack (most recent call first): ua_ros_p3dx/p3dx_control/CMakeLists.txt:7 (find_package)

-- Configuring incomplete, errors occurred! See also "/home/tatum/catkin_ws/build/CMakeFiles/CMakeOutput.log". See also "/home/tatum/catkin_ws/build/CMakeFiles/CMakeError.log". Invoking "cmake" failed

I have looked online to find an answer to this problem but the answers posted do not help me. I think this has to do with the fact that the the other questions were based on the indigo distribution. Please help!!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
3

answered 2015-08-13 01:31:54 -0600

mgruhler gravatar image

You don't have the controller_manager package installed. As ros_control is not yet release for Jade, try to clone the ros_control repository with git clone https://github.com/ros-controls/ros_control.git -b jade_devel and try again.

If (when) it is release, you can install it using `sudo apt-get install ros-jade-controller-manager'.

edit flag offensive delete link more

Comments

Thank you so much!!!! It worked!

thumper gravatar imagethumper ( 2015-08-13 09:40:39 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-08-12 18:03:45 -0600

Seen: 9,297 times

Last updated: Aug 13 '15