Ask Your Question
2

Move a P3AT robot with ROSARIA

asked 2012-11-19 07:07:20 -0500

MKnight gravatar image

updated 2014-04-20 14:09:49 -0500

ngrennan gravatar image

Hello.

I got a problem moving the Pioneer 3-AT. Please help me. I installed a package ROSARIA but I can't move the robot. I'm using Ubuntu 12.04 asn ROS fuerte.

To install ROSARIA I used :

roslocate info ROSARIA | rosws merge - rosws update The RosMake was OK.

If I run : rosrun ROSARIA RosAria, the computers connected with the robot.

NonCritical Error: ARIA could not find where it is located. ArLog::init: File(aria.log) Verbose Logging Time Not also printing ArSerialConnection::write:: Resource temporarily unavailable ArSerialConnection::write:: Resource temporarily unavailable ArSerialConnection::write:: Resource temporarily unavailable ArSerialConnection::write:: Resource temporarily unavailable ArSerialConnection::write:: Resource temporarily unavailable ArSerialConnection::write:: Resource temporarily unavailable ArSerialConnection::write:: Resource temporarily unavailable ArSerialConnection::write:: Resource temporarily unavailable ArSerialConnection::write:: Resource temporarily unavailable but If I publish some data to move the robot doesn't work !!

rostopic pub -r 10 /RosAria/cmd_vel geometry_msgs/Twist '[5,0,0]' '[0,0,0]'

Thanks

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
2

answered 2012-12-12 04:39:02 -0500

ReedHedges gravatar image

Hello,

Could be a permission problem on the serial port. First, make sure you are specifying the correct serial port. For example, if the robot is connected to your computer's first serial port (COM1), then use rosrun ROSARIA RosAria _port:=/dev/ttyS0 If it's /dev/ttyUSB0 (USB device) then use rosrun ROSARIA RosAria _port:=/dev/ttyUSB0 etc.

You will need permission to read and write that device. You can either add your user account to the appropriate user group to access the devices, or you can (as root) change the permissions on the serial port device in /dev, e.g. chmod a+rw /dev/ttyS0 (this permits any user on that computer to have full control over that serial port.)

Also, make sure no other program is using the same serial port.

Hope this helps...

edit flag offensive delete link more

Comments

Thanks. But I already check the serial port permission .... :-)

MKnight gravatar image MKnight  ( 2012-12-14 13:04:02 -0500 )edit
1

Also, if you have a USB serial port this method will not persist. Instead add your account the 'dialout' group in /etc/group instead. You will have to log out and back in again to take effect. (This was the solution to this problem for me)

Dereck gravatar image Dereck  ( 2013-01-30 11:45:24 -0500 )edit
0

answered 2013-01-31 05:10:14 -0500

Victor_ocv2 gravatar image

I also had this problem and found the solution by using both chmod and chown (chmod only is not enough)

Check the answer to this question: http://answers.ros.org/question/52066/problem-with-rosaria/

edit flag offensive delete link more
0

answered 2013-01-13 14:00:30 -0500

alessandrayoko gravatar image

I am with the same problem. Did you already fix it?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2012-11-19 07:07:20 -0500

Seen: 1,304 times

Last updated: Jan 31 '13