Ask Your Question
0

Error something to do with "libpcl_ros_tf.so" after migrating to Fuerte

asked 2012-11-10 21:13:02 -0600

alfa_80 gravatar image

updated 2012-11-11 06:54:45 -0600

I've just migrated from Electric to Fuerte. But after running a node via rosrun command, I received an error message as below:

error while loading shared libraries: libpcl_ros_tf.so: cannot open shared object file: No such file or directory

How do I fix this? Thanks in advance.

EDIT: Running the command "env | fgrep ROS" as suggested by @joq I receive:

ROS_ROOT=/opt/ros/fuerte/share/ros
ROSLISP_PACKAGE_DIRECTORY=/opt/ros/fuerte/share/common-lisp/ros
ROS_PACKAGE_PATH=/home/abc/code/ros_workspace:/opt/ros/fuerte/share:/opt/ros/fuerte/stacks
ROS_MASTER_URI=http://localhost:11311
ROS_DISTRO=fuerte
ROS_ETC_DIR=/opt/ros/fuerte/etc/ros
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2012-11-11 05:19:50 -0600

joq gravatar image

updated 2012-11-13 01:52:03 -0600

$ dpkg -S libpcl_ros_tf.so
ros-fuerte-perception-pcl: /opt/ros/fuerte/stacks/perception_pcl/pcl_ros/lib/libpcl_ros_tf.so

Do you have ros-fuerte-perception-pcl installed?

EDIT: I would try to get the basic Fuerte Ubuntu Debian package install working first, before tackling any source overlays. What does this print?

env | fgrep ROS

EDIT2: That mostly looks right. My system defines a few other things that could be significant:

ROS_WORKSPACE=/home/joq/ros/fuerte_dev
ROS_DISTRO=fuerte

Also, my ROS_PACKAGE_PATH ends with this:

/opt/ros/fuerte/stacks:/opt/ros/fuerte/share:/opt/ros/fuerte/share/ros

I don't know if any of that matters, but it's worth a try.

EDIT3: What if you reduce the package path to the minimum?

export ROS_PACKAGE_PATH=/opt/ros/fuerte/stacks:/opt/ros/fuerte/share:/opt/ros/fuerte/share/ros

EDIT4: Do you have this defined?

$ echo $LD_LIBRARY_PATH 
/opt/ros/fuerte/lib:

EDIT5: Frustrating, and I'll be away for the next few hours.

Does your node have <depend package="pcl_ros"> in its manifest.xml?

EDIT6: For future readers: when upgrading to a new ROS distribution, always rebuild your source trees from scratch. Either use make clean or check out a new working copy. The results of not doing that can be quite strange.

edit flag offensive delete link more

Comments

I have the library and in the path like above and when I install that package, it said it's already installed. Is this a bug in the Fuerte path management because it couldn't be able to search it automatically?

alfa_80 gravatar imagealfa_80 ( 2012-11-11 06:00:12 -0600 )edit

More likely there is something wrong with your $ROS_PACKAGE_PATH. There are some differences in the way the Fuerte environment variables are set up. Try sourcing /opt/ros/fuerte/setup.bash directly.

joq gravatar imagejoq ( 2012-11-11 06:09:31 -0600 )edit

It's already set as source /opt/ros/fuerte/setup.bash in my bashrc BTW and only that which is "source"d. Any other alternatives to resolve this?

alfa_80 gravatar imagealfa_80 ( 2012-11-11 06:13:16 -0600 )edit

Or do I need to apply the overlay(http://www.ros.org/wiki/fuerte/Installation/Overlays)? No need right because I just follow step-by-step instruction from this(http://www.ros.org/wiki/fuerte/Installation/Ubuntu).

alfa_80 gravatar imagealfa_80 ( 2012-11-11 06:40:26 -0600 )edit

@joq: I'm not on Debian anyway, I'm on ubuntu, perhaps I didn't get you.

alfa_80 gravatar imagealfa_80 ( 2012-11-11 06:56:36 -0600 )edit

I've tried to append and add some more configuration as you suggested, but still not resolved.

alfa_80 gravatar imagealfa_80 ( 2012-11-11 07:20:21 -0600 )edit

@joq: Reducing the package path also doesn't improve.

alfa_80 gravatar imagealfa_80 ( 2012-11-11 07:53:17 -0600 )edit

@joq: Yes, I do have. The same I receive as "/opt/ros/fuerte/lib:".

alfa_80 gravatar imagealfa_80 ( 2012-11-11 08:12:46 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-11-10 21:13:02 -0600

Seen: 528 times

Last updated: Nov 13 '12