Ask Your Question
1

How to install gtest in OS X mountain lion

asked 2012-10-23 02:39:31 -0600

tropic gravatar image

updated 2012-10-23 02:40:18 -0600

Hi

I have been struggling to get ROS to install properly in OS X Mountain Lion. I am very close, but I need to install gtest. This i cannot get it to do automatically through brew because Google does not recommend installing a pre-compiled copy of gtest as per their wiki.

Can anyone guide me through how to install gtest from the source so i can get on with the ROS installation? Seems to be the only hickup I have left.

Best regards

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
3

answered 2012-10-23 03:22:35 -0600

Hi tropic,

I had the same problem, check out this question: http://answers.ros.org/question/42335/mac-os-x-install-error-no-available-formula-for-gtest/

Hope it works for you.

edit flag offensive delete link more

Comments

I actually tried that but it did not work for me :/ I get the following when I run rosdep install -a No available formula for gtest (dependency of pcl)

tropic gravatar imagetropic ( 2012-10-23 03:34:59 -0600 )edit

Pay attention to the "UPDATE" on that question. Did you try adding the formula manually?

Martin Peris gravatar imageMartin Peris ( 2012-10-23 03:49:21 -0600 )edit

Edit: I am sorry, I placed the .rb file in the wrong folder, I had it in Taps/ros-fuerte instead of Formula. I realized this when I was installing the newest PLC from http://pointclouds.org/ and followed their toturial. It installed now. Thank you mate!

tropic gravatar imagetropic ( 2012-10-23 22:09:12 -0600 )edit

I am glad you managed to install it :)

Martin Peris gravatar imageMartin Peris ( 2012-10-23 23:33:21 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-10-23 02:39:31 -0600

Seen: 1,078 times

Last updated: Oct 23 '12