ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A answers.ros.org
Ask Your Question
2

ERROR: the following packages/stacks could not have their rosdep keys resolved to system dependencies

asked 2022-05-04 07:06:38 -0600

onkheisen gravatar image

Hello, I am trying to install Moveit with the version kinetic, when I type: frauas@frauas-Kinetic:~/ws_moveit$ rosdep install -y --from-paths . --ignore-src --rosdistro kinetic I received the error:

ERROR: the following packages/stacks could not have their rosdep keys resolved to system dependencies:

franka_example_controllers: Cannot locate rosdep definition for [libfranka] franka_gazebo: Cannot locate rosdep definition for [control_toolbox]: franka_visualization: Cannot locate rosdep definition for [libfranka]: franka_hw: Cannot locate rosdep definition for [libfranka] franka_control: Cannot locate rosdep definition for [libfranka] moveit_tutorials: Cannot locate rosdep definition for [joy] franka_gripper: Cannot locate rosdep definition for [libfranka]

Doing frauas@frauas-Kinetic:~/ws_moveit/src$ ls

franka_ros moveit_tutorials realtime_tools graph_msgs moveit_visual_tools ros_control libfranka panda_moveit_config rviz_visual_tools with "libfranka" inside, I do not where it should be.

I have follow the steps of: http://docs.ros.org/en/kinetic/api/mo...

Thank you in advance for your help.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2022-05-04 07:31:30 -0600

ljaniec gravatar image

updated 2022-05-04 07:32:40 -0600

Have you tried building the franka_ros packages?

E.g. with these steps there: https://frankaemika.github.io/docs/in...

What errors do you see there?

Do you have these installed

sudo apt-get install ros-kinetic-ros-control ros-kinetic-ros-controllers 
sudo apt-get install ros-kinetic-gazebo-ros-control

?

edit flag offensive delete link more

Comments

2

Would it have something to do with kinetic being EOL? Doesn't rosdep update skip EOL distributions?

EDIT in that case, they should try rosdep update --include-eol-distros and try again to run rosdep install --from-paths src --ignore-src -r -y

Joe28965 gravatar image Joe28965  ( 2022-05-04 08:13:53 -0600 )edit

I didn't know this flag --include-eol-distros for rosdep, thank you :) It's worth a shot for sure!

ljaniec gravatar image ljaniec  ( 2022-05-05 01:44:30 -0600 )edit

@Joe28965 was right, I tryed with rosdep update --include-eol-distros and later again with my rosdep install -y --from-paths . --ignore-src --rosdistro kinetic again and it was fixed. I will study what EOL distributions are.

Thank you so much to both of you, have a nice day.

onkheisen gravatar image onkheisen  ( 2022-05-05 03:45:49 -0600 )edit

EOL means End Of Life - http://wiki.ros.org/Distributions It's not longer actively supported. You can accept this answer and upvote comments to let others see that it's solved

ljaniec gravatar image ljaniec  ( 2022-05-05 07:32:38 -0600 )edit

Thanks @ljaniec

onkheisen gravatar image onkheisen  ( 2022-05-06 02:25:39 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2022-05-04 07:06:38 -0600

Seen: 2,333 times

Last updated: May 04 '22