Ask Your Question
0

laser_scan_matcher bulding package on Fuerte

asked 2012-10-14 05:57:52 -0500

alfa_80 gravatar image

I've successfully set up laser_scan_package on Electric. Now, I would like to build laser_scan_matcher package on Fuerte but I got the following error message:

 CSM previously patched, use make wipe to completely remove build directory.
 cd build/csm-git && mkdir -p deploy
 cd build/csm-git && cmake -DCMAKE_INSTALL_PREFIX:PATH=/opt/ros/fuerte/stacks/scan_tools/csm -DCMAKE_C_FLAGS:STRING="-fPIC"
-- Create a file named 'local_config/local-user-laptop.cmake' if you want to add options.
gsl home: 
DBG GSL_CONFIG GSL_CONFIG-NOTFOUND
FATAL_ERROR,FindGSL.cmake: gsl-config not found. Please set it manually.      
GSL_CONFIG=GSL_CONFIG-NOTFOUND
CMake Error at sm/CMakeLists.txt:30 (MESSAGE):
GSL not found.

How to solve the GSL problem. Thanks in advance.

edit retag flag offensive close merge delete

Comments

@alfa_80 what is the command of installing laser_scan_package on Fuerte ?

marwa gravatar image marwa  ( 2013-02-01 08:35:00 -0500 )edit
1

Last time I used, I've just checkout via git from the repository on ros.org. But now, when I was trying to search the link for you, it returns an error of ""laser_scan_matcher" is either not a ROS package or not yet indexed." I think, it's yet to be indexed..wait until next Monday perhaps :-)

alfa_80 gravatar image alfa_80  ( 2013-02-01 08:52:43 -0500 )edit

OK..thanks :)

marwa gravatar image marwa  ( 2013-02-01 20:01:10 -0500 )edit

@marwa: here is the command: "git clone https://github.com/ccny-ros-pkg/scan_tools.git", the laser_scan_matcher should reside in the scan_tools directory. Hope that helps..

alfa_80 gravatar image alfa_80  ( 2013-02-03 22:46:27 -0500 )edit

Thank you :)

marwa gravatar image marwa  ( 2013-02-03 22:52:11 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
7

answered 2012-10-14 09:30:20 -0500

Eric Perko gravatar image

Did you make sure you install all required dependencies first (e.g. via rosdep install)?

The quick fix would be to do apt-get install gsl0-dev and that would get you the required GSL dependency.

edit flag offensive delete link more

Comments

Thanks a lot, that works :-)

alfa_80 gravatar image alfa_80  ( 2012-10-15 09:18:06 -0500 )edit
2

just a small correction> sudo apt-get install libgsl0-dev

martimorta gravatar image martimorta  ( 2013-05-27 05:49:24 -0500 )edit

Thanks! They must have their package set up slightly wrong or outdated because I ran rosdep install and it said that everything was there.

kwiesz91 gravatar image kwiesz91  ( 2015-09-10 10:07:33 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-10-14 05:57:52 -0500

Seen: 1,025 times

Last updated: Oct 14 '12