Ask Your Question
0

Running move_base with gmapping

asked 2011-12-15 19:49:55 -0500

tom gravatar image

I went though all relevantly tagged questions here and some tutorials, but still can't figure out what's wrong with my setup. As in subject, I'd like to configure move_base to work with gmapping on-line - gmapping is configured correctly, hence running. My config is mostly as described in Navigation Setup Wiki-post, ie.:

costmap_common_params.yaml:

obstacle_range: 2.5
raytrace_range: 3.0
robot_radius: 0.5
inflation_radius: 0.55

observation_sources: laser_scan_sensor

laser_scan_sensor: {sensor_frame: /laser, data_type: LaserScan, topic: /scan, marking: true, clearing: true}

global_costmap_params.yaml:

global_costmap:
  global_frame: /map
  robot_base_frame: base_link
  update_frequency: 5.0
  static_map: false

local_costmap_params.yaml:

local_costmap:
  global_frame: world
  robot_base_frame: base_link
  update_frequency: 5.0
  publish_frequency: 2.0
  static_map: false
  rolling_window: true
  width: 6.0
  height: 6.0
  resolution: 0.05

base_local_planner_params.yaml:

TrajectoryPlannerROS:

  max_vel_x: 0.1 #m/s
  min_vel_x: 0.0
  escape_vel: -0.1
  max_rotational_vel: 0.1 #rad/s
  min_in_place_rotational_vel: 0.0

  y_vels: [-0.1, -0.0, 0.0, 0.1]

  acc_lim_th: 1.0
  acc_lim_x: 1.0 #m/s2
  acc_lim_y: 1.0

  holonomic_robot: true

move_base.launch:

<launch>
  <master auto="start"/>

  <node pkg="move_base" type="move_base" respawn="false" name="move_base" output="screen">
    <rosparam file="$(find my_robot)/costmap_common_params.yaml" command="load" ns="global_costmap" />
    <rosparam file="$(find my_robot)/costmap_common_params.yaml" command="load" ns="local_costmap" />
    <rosparam file="$(find my_robot)/local_costmap_params.yaml" command="load" />
    <rosparam file="$(find my_robot)/global_costmap_params.yaml" command="load" />
    <rosparam file="$(find my_robot)/base_local_planner_params.yaml" command="load" />
  </node>
</launch>

I launch laser-scan based gmapping before and it's all functional. I selected \world as odom frame in all gmapping packages, so I repeated this in move_base as well, hope this shouldn't be a problem. In rviz I selected move_base_simple in Tool properties -> 2D Nav Goal -> Topic. Yet, when I define a goal, nothing gets published on /cmd_vel topic.

What else do I need? Any hints appreciated.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
3

answered 2011-12-15 21:21:40 -0500

raahlb gravatar image

updated 2011-12-15 21:24:05 -0500

Hi, You should set the goal topic to "move_base_simple/goal", not just "move_base_simple". Or was that just a typo? IIRC there are several other goal topics also, at least in my setup. You could try them too.

You can also use the command "rxgraph" to make sure that all the nodes are correctly connected, so there isn't a gap somewhere. Can be kind of hard if there are several package internal nodes and you don't really know which topics should be forwarded where, though...

edit flag offensive delete link more

Comments

Nope, not a typo :)
tom gravatar image tom  ( 2011-12-15 22:09:23 -0500 )edit
0

answered 2011-12-15 21:54:24 -0500

michikarg gravatar image

Raahlb is right, you need to set the topic to move_base_simple/goal. Of course you also need to localize your robot, i.e. the Pose of the robot has to be published on the correct topic.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-12-15 19:49:55 -0500

Seen: 1,740 times

Last updated: Dec 15 '11