Ask Your Question
0

NAO + ROS: walking : Howto? [closed]

asked 2012-10-08 03:22:48 -0500

Idontknowit gravatar image

updated 2012-10-10 03:48:27 -0500

Hi everybody. I am trying to make my NAO walk using the nao_driver. But i can't get this thing working. It would be very kind of you, if someone can give me i hint on how doing so.

I tried several things. One in all i tried to publish a message to /cmd_vel

rostopic pub -1 /cmd_vel geometry_msgs/Twist '{linear: {x: 1.0, y: 0.0, z: 0.0}, angular: {x: 0.0, y: 0.0, z: 0.0}}'

publishing and latching message for 3.0 seconds

but nothing happens - the NAO does not move.

rostopic echo /cmd_vel

shows me that the value is correctly changed. But anyway the values in

rostopic echo /torso_odometry

stay the same and do not change.

Thank you for your help.


Edit:

I solved my problem: I forgot to enable the stiffness.

To do so just use (stiffness for whole body):

rosservice call /body_stiffness/enable "{}"

Now it works. :-)

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Vincent Rabaud
close date 2014-08-01 06:28:10.039550

1 Answer

Sort by ยป oldest newest most voted
2

answered 2012-10-10 03:07:07 -0500

Idontknowit gravatar image

okay. i fixed it. The reason why i did not work was because i did not set stiffness to enable.

example (setting the stiffness for the whole body:

rosservice call /body_stiffness/enable "{}"
edit flag offensive delete link more

Comments

are u making the actual robot walk or doing this in a virtual environment?

uzair gravatar image uzair  ( 2013-10-31 16:13:03 -0500 )edit

Question Tools

Stats

Asked: 2012-10-08 03:22:48 -0500

Seen: 917 times

Last updated: Oct 10 '12