Ask Your Question
0

Can't get image from nao_camera

asked 2013-07-01 23:05:06 -0500

pseudobot gravatar image

updated 2013-07-02 06:18:46 -0500

Hello, I want some help.

I am using NAO right now. I follow this tutorial : www.ros.org/wiki/nao/Tutorials/Getting-Started

and I can make it walk, etc.

INFO : I am using this version -> pynaoqi-python-2.7-naoqi-1.12.5-linux64

But, I need the image from NAO camera.

So, in the nao_driver, I add this :

<node pkg="nao_driver" type="nao_camera.py" name="nao_camera" required="true" args="--pip=$(arg nao_ip) --pport=$(arg nao_port)" output="screen"/>

Then I run :

rostopic list -v

Result :

zangetsu@ubuntu:~/fuerte_workspace$ rostopic list -v

Published topics:
 * /image_raw [sensor_msgs/Image] 1 publisher
 * /rosout [rosgraph_msgs/Log] 6 publishers
 * /joint_states [sensor_msgs/JointState] 1 publisher
... etc ...

and ROS said the /image_raw topic is there.

But when I run this :

rosrun image_view image_view image:=/image_raw

Nothing happens, just a gray screen in the frame.

edit retag flag offensive close merge delete

Comments

No idea, but just a comment: You could also try reporting the problems (& wishes) at the ROS/Nao mailing list

AHornung gravatar image AHornung  ( 2013-07-02 03:13:43 -0500 )edit

Is there anyone who success run it before ?

pseudobot gravatar image pseudobot  ( 2013-07-02 03:17:15 -0500 )edit

btw, I got this error when I try execute : > rostopic echo /image_raw

WARNING: no messages received and simulated time is active. Is /clock being published

pseudobot gravatar image pseudobot  ( 2013-07-02 03:44:00 -0500 )edit

Why do you have the sim time parameter enabled, are you playing back from a bag file? Are you using "--clock" with "rosbag play"?

AHornung gravatar image AHornung  ( 2013-07-02 04:11:25 -0500 )edit

no, I connect it directly to NAO. I didn't use rosbag. I am using the real robot.

pseudobot gravatar image pseudobot  ( 2013-07-02 04:18:32 -0500 )edit

Well, something set "/use_sim_time" to True, it needs to be False

AHornung gravatar image AHornung  ( 2013-07-02 04:26:12 -0500 )edit

hmm I check with rosparam get use_sim_time, the result is false ...

@AHornung but when I try to run it manually with this script

http://www.aldebaran-robotics.com/documentation/_downloads/videoInput_getImage.py

it stuck at this line : nameId = camProxy.subscribe("python_GVM", resolution,

pseudobot gravatar image pseudobot  ( 2013-07-02 06:17:35 -0500 )edit

I have similar issue, I can't launch the process because it's dying in the middle of the launch, I have managed to get to know, and it's dying at the same line camProxy.subscribe("rospy_gvm", self.resolution, self.colorSpace, self.fps)

asiron gravatar image asiron  ( 2014-06-04 12:07:38 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-07-02 17:07:18 -0500

pseudobot gravatar image

Well, actually today I can retrieve image from nao_camera ... and I don't know why yesterday they just give me a gray image either ROS or the NaoQI (via python).

But, I can retrieve it "after" I open monitor software (in the same folder as Choreograph).

So, for the one who has got same problem with me. Maybe you can try to launch Monitor software and click Play button. After that mine is fixed.

edit flag offensive delete link more

Comments

do you use the old version of the NAO head? Maybe it is necessary to "select" one camera before the topics are produced (The old NAO can just use one camera at a time).

MichaelKorn gravatar image MichaelKorn  ( 2013-07-03 01:40:27 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-07-01 23:05:06 -0500

Seen: 601 times

Last updated: Jul 02 '13