Ask Your Question
0

interactive markers and point cloud catch 22 in rviz

asked 2012-09-27 06:21:21 -0500

baxelrod gravatar image

updated 2012-09-27 06:35:01 -0500

I seem to have a catch 22 situation using interactive markers and point clouds in rviz. What i am trying to do is manually align multiple planar laser scans with interactive markers. (I know that there is a scan matching package, but there is very little overlap between my lasers, and i was just trying to do something quick and dirty). the laser scans have been converted to PointCloud2 types. My interactive marker node simply takes the marker position and broadcasts this pose to tf. I am using Fuerte on Ubuntu 12.04, with roscore on an external machine.

  1. my interactive markers don't seem to work unless i start rviz before launching my (python) interactive marker node.

  2. my pointclouds don't seem to display in rviz unless they are publishing before rviz starts.

  3. starting my lasers, then rviz, then the interactive markers doesn't work because rviz can't find the tf frames for the laser scans. (This restriction isn't an issue when the rosmaster is local).

Is there any workaround for this? Perhaps a way to get rviz to refresh or reload tf info when using an external master? or is there a way to publish a long lasting tf frame before my laser nodes start, then i can override this frame with the interactive markers later?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2012-09-27 06:57:52 -0500

Lorenz gravatar image

updated 2012-09-27 06:59:29 -0500

In ROS it should never matter in which order you start up your nodes. If topics do not connect, I suspect that something is fishy with the network configuration. Try setting ROS_IP on all computers involved.

edit flag offensive delete link more

Comments

i think you are right. i can only ping in one direction.

baxelrod gravatar image baxelrod  ( 2012-09-27 07:16:07 -0500 )edit
0

answered 2012-09-27 06:39:56 -0500

I'm not sure why rviz is acting how it is (that doesn't seem like the correct behavior). I wrote a node similar to static_transform_publisher that is exposed to dynamic_reconfigure. I think you could solve your problem by starting up this node with some arbitrary transform, and rather than having your python node directly publish a transform, have it act as a dynamic_reconfigure client and update the transform.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-09-27 06:21:21 -0500

Seen: 507 times

Last updated: Sep 27 '12