Ask Your Question
0

ssh doesn't work over WiFi [closed]

asked 2012-09-05 18:41:44 -0600

KM6VV gravatar image

I can SSH to myself on both the 'bot and the workstation, but not one to another. What would prevent ssh from working over WiFi? Ping works all 4 ways.

Alan

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by tfoote
close date 2012-09-09 21:45:31

Comments

What is the error that is shown? Are you specifying the correct names for ssh?

SivamPillai gravatar imageSivamPillai ( 2012-09-06 03:53:40 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted
1

answered 2012-09-09 18:06:51 -0600

KM6VV gravatar image

It works!

had to ssh turtlebot@turtlebot-0170 (and turtlebot as password) and ssh alan@alan-desktop (and my password).

I had been trying: ssh 172.16.1.22 (sample) I thought "Mervin" was just the IP.

Thanks all!

Alan

edit flag offensive delete link more
0

answered 2012-09-05 21:55:20 -0600

kszonek gravatar image

What do you mean by ssh to yourself? Is it "ssh localhost"? If so, then I guess you have ssh server installed.

Do you access remote mashine with hostname or IP? If hostname, try using IP address instead. You can get them with

ifconfig wlan0

edit flag offensive delete link more
0

answered 2012-09-05 18:59:03 -0600

I don't know if this is the appropriate place to ask this question, but have you installed openssh-server in both machines?

https://help.ubuntu.com/10.04/serverguide/openssh-server.html

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-09-05 18:41:44 -0600

Seen: 667 times

Last updated: Sep 09 '12