Ask Your Question
0

Running gazebo remotely in fuerte

asked 2012-08-28 07:01:52 -0500

jbarry gravatar image

updated 2012-08-28 07:45:53 -0500

Hi,

I would like to be able to run Gazebo remotely on a computer that is faster than my own computer. Pre-fuerte, this could be done by ssh'ing into the remote machine and running

roslaunch gazebo_worlds empty_world_no_x.launch

In fuerte, this crashes gazebo. I have tried using the -X flag with ssh and also setting export DISPLAY=:0 with no luck. I have also tried

roslaunch gazebo_worlds empty_world.launch gui:=false

and that also crashed trying to open a display with normal ssh. When ssh'd with -X, it crashes with the following error:

X Error of failed request:  GLXUnsupportedPrivateRequest
  Major opcode of failed request:  154 
  Minor opcode of failed request:  16 (X_GLXVendorPrivate)
  Serial number of failed request:  27
  Current serial number in output stream:  28

Is there a way to run Gazebo remotely in Fuerte?

Thanks,

Jenny

edit retag flag offensive close merge delete

Comments

Hello! I assume that you are still ssh'ing to the same physical machine? What is the value of DISPLAY when you login to the machine directly (i.e. not over the network)? What type of graphics card are you using?

SL Remy gravatar image SL Remy  ( 2012-08-30 02:00:43 -0500 )edit

Yes, I'm always ssh'ing into the same physical machine. The value of DISPLAY is :16.0 and the graphics card is nVidia 10de:0e22 (which I think is a GeForce GTX 460 although 10de:0e22 seems to be all I can actually get the computer to tell me). Thanks!

jbarry gravatar image jbarry  ( 2012-08-30 05:54:44 -0500 )edit

fixes in fuerte branch. If you checkout simulator_gazebo and compile from source, you can change USE_HG to true in simulator_gazebo/gazebo/CMakeLists.txt to try it out.

hsu gravatar image hsu  ( 2012-08-30 10:54:02 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-09-11 07:53:36 -0500

jbarry gravatar image

updated 2012-09-11 07:55:32 -0500

By checking out simulator_gazebo and compiling from source as suggested in the comment (although I didn't actually change USE_HG - it worked for me out of the box) I was able to get this working by launching

roslaunch gazebo_worlds empty_world.launch gui:=false

Thank you!

edit flag offensive delete link more

Comments

Update: This is still not working in /opt for me (we pull from /ros/ubuntu not shadow) but does work locally. I did have to update gazebo-1.6 to make it work with what I think are changes in pr2_gazebo.

jbarry gravatar image jbarry  ( 2013-02-15 06:28:41 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-08-28 07:01:52 -0500

Seen: 418 times

Last updated: Sep 11 '12