Ask Your Question
0

Gazebo is not publishing clock

asked 2017-02-27 06:35:38 -0600

WLemkens gravatar image

My Gazebo is not publishing the clock anymore. I don't know what I did wrong. A few days ago it worked, but not anymore.

"use_sim_time" is set to true (rosparam get use_sim_time returns true) The time in the simulator is running.

I used the sasc version of Gazebo (Gazebo 8.0), but reverting to 7.5 doesn't change it.

Between the last time it worked and the first time I noticed it doesn't work anymore, I installed CUDA 8 and compiled OpenCV 3.1 from source. But I also reverted back to CUDA 7.5 and the default opencv of my system which doesn't make it work.

It seems to me that on no other topics something is published either. But if I manually publish something (i.e. rostopic pub /test std_msgs/String "test" -r 5) I can display the content via rostopic echo.

Any clues of what might be wrong?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2017-02-27 07:52:13 -0600

gvdhoorn gravatar image

If nothing is publishing, check firewalls and whether you have a ROS_IP, ROS_HOSTNAME or ROS_MASTER_URI setting in your .bashrc that points to wrong IP addresses.

edit flag offensive delete link more

Comments

Yes thank you! It was pointing to 127.0.0.1 instead of my real ip-address.

WLemkens gravatar imageWLemkens ( 2017-02-27 08:25:31 -0600 )edit

What was pointing to 127.0.0.1? In any case, that should probably also work.

gvdhoorn gravatar imagegvdhoorn ( 2017-02-27 08:42:17 -0600 )edit

ROS_IP and ROS_MASTER_URI were pointing to 127.0.0.1. After changing it to use the ip of my network card the messages were working again.

WLemkens gravatar imageWLemkens ( 2017-02-27 08:59:10 -0600 )edit

If you are not trying to distribute your ROS application across multiple networked hosts, the setting all of those is probably not necessary. Not setting them will allow ROS to detect proper values for them automatically.

gvdhoorn gravatar imagegvdhoorn ( 2017-02-27 09:17:05 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-02-27 06:35:38 -0600

Seen: 589 times

Last updated: Feb 27 '17