ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

SSH into Turtlebot?

asked 2012-08-08 05:37:35 -0600

buma676 gravatar image

updated 2012-08-08 08:17:18 -0600

So my workstation and computer are finally connected, and now it tells me to ssh into the laptop from the workstation. When I type in "ssh turtlebot@" (the ip of the laptop being, I am prompted to enter a password. The password is not the normal password of the computer, and when I guess incorrectly three times, it tells me "Permission denied (publickey,password)". what does this mean? how do I find the publickey?

**Here is the info of the laptop**
hyness@turtlebot:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr 10:bf:48:16:d7:9d  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:43 Base address:0xc000 

eth1      Link encap:Ethernet  HWaddr 94:db:c9:9c:b3:ba  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::96db:c9ff:fe9c:b3ba/64 Scope:Link
          RX packets:115679 errors:0 dropped:0 overruns:0 frame:410389
          TX packets:107116 errors:19 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:32919823 (32.9 MB)  TX bytes:16498997 (16.4 MB)

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:187731 errors:0 dropped:0 overruns:0 frame:0
          TX packets:187731 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:24223708 (24.2 MB)  TX bytes:24223708 (24.2 MB)

**From Workstation**
ssh turtlebot@
turtlebot@'s password: 
Permission denied, please try again.
turtlebot@'s password: 
Permission denied, please try again.
turtlebot@'s password: 
Permission denied (publickey,password)'


edit retag flag offensive close merge delete



Normal password of which computer? It should be the password of the turtlebot user on the laptop. Did you try that?

dornhege gravatar image dornhege  ( 2012-08-08 06:04:42 -0600 )edit

yes, I tried that multiple times... why does it mention publickey?

buma676 gravatar image buma676  ( 2012-08-08 08:01:08 -0600 )edit

did you copy your workstations public ssh key to the turtlebot laptop? If so, you might have entered a passphrase for that specific key. Try that one.

bit-pirate gravatar image bit-pirate  ( 2012-08-08 13:49:58 -0600 )edit

Thanks! I actually figured this out just now, but i appreciate it!

buma676 gravatar image buma676  ( 2012-08-10 05:10:45 -0600 )edit

Hi, I am completely new to turtlebot and linux, i am facing the same problem too, I am just using one laptop connected to the turtlebot. When i type in turtlebot@'s password: Permission denied, please try again. I have tried the root password but it didnt work. How to find the password?

Bharath Javvadhi gravatar image Bharath Javvadhi  ( 2014-10-13 16:13:00 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2012-08-09 09:50:53 -0600

allenh1 gravatar image

The way you are using ssh, you are ssh-ing the turtlebot acount on turtlebot. If you entered "turtlebot", the default password for the turtlebot account, it should log you in. So, to log into your account, run this instead:

ssh hyness@
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools


Asked: 2012-08-08 05:37:35 -0600

Seen: 2,086 times

Last updated: Aug 09 '12