Ask Your Question
2

Issues about Installing ROS on Mountain Lion

asked 2012-09-04 23:31:57 -0500

Klinux gravatar image

updated 2012-09-08 13:25:05 -0500

Kevin gravatar image

Hi, I'm trying to install ROS on Mac OSX 10.8.1, following electric Homebrew Installation. And after fixing(hopefully) the boost lib problem, new one comes:

[ rosmake ] Generating Install Script using rosdep then executing. This may take a minute, you will be prompted for permissions. . . [ rosmake ] rosdep install failed: unrecognized version: 10.8.1

Traceback (most recent call last): File "/usr/local/bin/rosinstall", line 16, in <module> sys.exit(not rosinstall_main(sys.argv)) File "/Library/Python/2.7/site-packages/rosinstall/rosinstall_cli.py", line 228, in rosinstall_main options.catkinpp) File "/Library/Python/2.7/site-packages/rosinstall/rosinstall_cmd.py", line 100, in cmd_generate_ros_files subprocess.check_call("source %s && rosmake ros%s --rosdep-install%s" % (os.path.join(path, 'setup.sh'), ros_comm_insert, rosdep_yes_insert), shell=True, executable='/bin/bash') File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/subprocess.py", line 511, in check_call raise CalledProcessError(retcode, cmd) subprocess.CalledProcessError: Command 'source /Users/Klinux/ros/setup.sh && rosmake ros ros_comm --rosdep-install' returned non-zero exit status 1

I searched on google but didn't get any results, so could anybody help me out of this? Thanks a lot...

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
1

answered 2012-09-05 04:36:33 -0500

I ran into a similar issue installing Fuerte. Adding a version number for Mountain Lion to rospkg/os_detect.py:220 fixed the issue for me.

_osx_codename_map = {4: 'tiger', 5: 'leopard', 6: 'snow', 7: 'lion', 8: 'mountain lion'}

edit flag offensive delete link more

Comments

I'm not sure where that map is used in the rest of ROS so someone with more knowledge of the system than me might could comment on whether a space is acceptable in the os name.

david.hodo gravatar imagedavid.hodo ( 2012-09-05 04:40:04 -0500 )edit

thanks for your answer, actually after that I pass the making, strange though, but new problem comes out.... and I change to ubuntu. so I cannot test if your suggestion does the trick or not. but thanks anyway.

Klinux gravatar imageKlinux ( 2012-09-06 21:15:16 -0500 )edit
0

answered 2012-11-22 02:41:04 -0500

Hey guys, I hope I can help you with my tutorial: https://github.com/PhDittmann/ros-for-mac/wiki

edit flag offensive delete link more
0

answered 2012-10-20 21:09:48 -0500

Arthur gravatar image

Yes I have the same problem here - not clear if ROS is working with the mountain lion OS yet

edit flag offensive delete link more

Comments

I run ROS on 10.8.2, but the GUI stuff doesn't compile right now. There is also a limitation with the ros_pcl stuff. But the majority of ROS runs. Hopefully when groovy comes out soon, most of these issues will be fixed.

Kevin gravatar imageKevin ( 2012-10-25 13:26:02 -0500 )edit

I have the ROS base for groovy compiled on 10.8 already. The instructions are here.

Kevin gravatar imageKevin ( 2012-11-24 16:27:35 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-09-04 23:31:57 -0500

Seen: 767 times

Last updated: Nov 22 '12