ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Incomplete configuration during ROS Hydro installation on OSX 10.9

asked 2014-06-05 17:34:41 -0600

jc17 gravatar image

updated 2014-06-09 18:38:42 -0600

Hello everyone, I am an absolute beginner when it comes to ROS or Homebrew or even using the Terminal! Please bear with me here.

I've been following this tutorial ( to the letter trying to install ROS Hydro to my Mac OSX 10.9. I am stuck at section 2.1.3 where I'm told to run ./src/catkin/bin/catkin_make_isolated --install -DCMAKE_BUILD_TYPE=Release. Upon running it, the command fails with this error:

-- Configuring incomplete, errors occurred!
See also "/Users/jcRebanal/ros_catkin_ws/build_isolated/catkin/CMakeFiles/CMakeOutput.log".
<== Failed to process package 'catkin': 
  Command 'cmake /Users/jcRebanal/ros_catkin_ws/src/catkin -DCATKIN_DEVEL_PREFIX=/Users/jcRebanal/ros_catkin_ws/devel_isolated/catkin -DCMAKE_INSTALL_PREFIX=/Users/jcRebanal/ros_catkin_ws/install_isolated -DCMAKE_BUILD_TYPE=Release' returned non-zero exit status 1

Reproduce this error by running:
==> cd /Users/jcRebanal/ros_catkin_ws/build_isolated/catkin && cmake /Users/jcRebanal/ros_catkin_ws/src/catkin -DCATKIN_DEVEL_PREFIX=/Users/jcRebanal/ros_catkin_ws/devel_isolated/catkin -DCMAKE_INSTALL_PREFIX=/Users/jcRebanal/ros_catkin_ws/install_isolated -DCMAKE_BUILD_TYPE=Release

Command failed, exiting.

I have no idea how I can continue installation from here, may it have something to do with the command cmake /...Release ending with returned non-zero exit status 1? Like I said, I'm an absolute beginner here and can't make sense of this or how to proceed.

I DID try running brew doctor and I was told my system is ready to brew with no warnings.

The rest of the installation up to this point was relatively smooth and was only met with one other major warning/error. At tutorial section 2.1.2 I'm told to resolve dependencies. I ran rosdep install --from-paths src --ignore-src --rosdistro hydro -y and at the end of the command I was asked my sudo password. I was met with this error:

Could not find any downloads that satisfy the requirement PIL

Some externally hosted files were ignored (use --allow-external PIL to allow).

No distributions at all found for PIL.

Storing debug log for failure in /Users/.../pip.log

Error: the following rosdeps failed to install: pip: command [sudo pip install -U PIL] failed

Not sure if that's relevant or not but it does provide more detail on my situation. I could not find anyone else having the same problem, I have no idea if this is easily fixable or if this is a hard compatibility issue.

Please, if you can provide any insight, I would appreciate it very much. I can provide other details if needed. Thank you!!

edit 1: Using both William's and demmein's answers did solve my original PIL install issue. However, I still ended up getting stuck installing the rosdeps, mainly pcl. I dropped trying to install ROS on OSX 10.9 and installed it on Ubuntu and ran than on OSX through VirtualBox. I used a .ova file with ROS Hydro pre-installed and have been able to use it without issue since. Here is the link I used: ( (I used the 3.7 GB torrent). Thanks again everyone for the help!

edit retag flag offensive close merge delete


I actually think it did solve your original issue, you just ran into a different, similar error later with PCL...

William gravatar image William  ( 2014-06-09 18:29:40 -0600 )edit

My original issue was not being able to run './src/catkin/bin/catkin_make_isolated --install -DCMAKE_BUILD_TYPE=Release' and I still wasn't able to run it and continue with the installation. But your answer and demmein's helped and definitely resolved the PIL issue. And they're both appreciated! (:

jc17 gravatar image jc17  ( 2014-06-09 18:55:49 -0600 )edit

Feel free to post a new question with more details about the pcl issue. In general ROS on Ubuntu will be more of smooth sailing than on OS X, however some things don't always work great in a VM, such as visualization in rviz.

demmeln gravatar image demmeln  ( 2014-06-10 14:34:25 -0600 )edit

3 Answers

Sort by » oldest newest most voted

answered 2014-06-05 18:31:50 -0600

William gravatar image

The snippet you provided doesn't show the error, all of the interesting stuff would have happened above the -- Configuring incomplete, errors occurred! line. Everything that follows is just letting you know that the build failed and how you can reproduce it manually if you so desired.

However, regardless of that error, the other snippet you posted probably indicates the issue with the CMake error. If you got Error: the following rosdeps failed to install: pip: command [sudo pip install -U PIL] failed then that means that not only was PIL not installed, but rosdep also didn't install any of the dependencies which followed. You can see what rosdep still needs to install (without actually installing anything) by running this command:

$ rosdep install --from-paths src --ignore-src --rosdistro hydro -y --simulate

Unless you get #All required rosdeps installed successfully, or nothing, back from rosdep, then you have unmet system dependencies still. I would imagine you have several, but at least PILshould be there.

You have one of two options, first you can figure out why PIL is not installing and install it manually, or you can tell rosdep to skip that dependency by adding --skip-keys=python-imaging (python-imaging is the rosdep key which resolves to PIL on pip).

I believe your PIL install error, gives you the solution:

Some externally hosted files were ignored (use --allow-external PIL to allow).

So if you run this, it should probably install:

$ sudo pip install --allow-external -U PIL

Then you should be able to run rosdep again and get the rest of the dependencies. Once you have gotten all of your dependencies installed, you will probably be able to run catkin_make_isolated.

edit flag offensive delete link more


I really appreciate the reply, William! Your suggestion did not work seamlessly but it definitely pointed me in the right direction. I was able to install PIL 1.1.7. However, now when I try to run 'rosdep install –-from-paths /Users/jcRebanal/ros_catkin_ws/src –-ignore-src --rosdistro hydro -y' ...

jc17 gravatar image jc17  ( 2014-06-06 12:12:59 -0600 )edit

... I get "the following rosdeps failed to install: homebrew: command [brew install pcl] failed". I ran brew update then I ran brew doctor no problem. I tried to run 'brew install pcl' and I got the same issue. In the error it mentions "make: *** [cmake_check_build_system] Error 1" followed by ...

jc17 gravatar image jc17  ( 2014-06-06 12:14:58 -0600 )edit

... a link to the github homebrew troubleshooting site. So it seems the rosdep 'brew install pcl' can't install and I'm stuck there now. My Xcode is updated and am looking for solutions right now!

jc17 gravatar image jc17  ( 2014-06-06 12:15:55 -0600 )edit

Not sure about the PCL problem, it might be worth a new question. Also in the future, you can update your question when comments are not big enough.

William gravatar image William  ( 2014-06-06 13:41:43 -0600 )edit

If one of these answers resolves your original PIL question, please press the check mark. If you still have a problem with PCL, please open a new question, or ask on the mailing list.

joq gravatar image joq  ( 2014-06-07 11:51:30 -0600 )edit

answered 2014-06-06 04:09:42 -0600

demmeln gravatar image

updated 2014-06-10 14:36:06 -0600

On top of what @William wrote, on 10.9 you probably also need the following patches before you can build all packages with catkin_make_isolated. Go to your workspace and execute the following

pushd src/orocos_kinematics_dynamics
curl | patch -p1
curl | patch -p1

pushd src/robot_model
curl | patch -p1

pushd src/robot_state_publisher
curl | patch -p1

pushd src/opencv2
curl | patch

And you should delete the build folder once after applying these patches to make sure there is no stale cmake configuration.

edit flag offensive delete link more


Thank you for the reply demmein. The patches went without issue except the last one (opencv2), the terminal said "patch ends unexpectedly in middle of line". Also, exactly what build folder are you referring to? ~/ros_catkin_ws/build_isolated ?? Sorry I'm so clueless about this sort of thing..!

jc17 gravatar image jc17  ( 2014-06-06 12:20:28 -0600 )edit

You can ignore that error about the last patch. It should still habe applied find. And yes, i was referrong to the build_isolated folder.

demmeln gravatar image demmeln  ( 2014-06-06 19:13:40 -0600 )edit

answered 2015-03-10 03:06:37 -0600

vince gravatar image

Hello everyone, I got the same issue than jc17 and I didn't find a way to fix it. Does one of you find a way to pass through it? Thanks!

edit flag offensive delete link more


What does not work. A lot has changed since this question was opened, and people are successfully compiling ROS indigo on OS X 10.9, see . Otherwise, please open a new question with more specifics about your exact issues.

demmeln gravatar image demmeln  ( 2015-03-10 18:32:07 -0600 )edit

Question Tools

1 follower


Asked: 2014-06-05 17:34:41 -0600

Seen: 924 times

Last updated: Mar 10 '15