Ask Your Question
0

Having trouble installing PIL in Mac OSX

asked 2014-03-28 10:54:16 -0600

KennethChaney gravatar image

updated 2014-03-29 11:07:39 -0600

demmeln gravatar image

Hi all,

I am currently trying to install row in osx--my work requires that I work in mac as opposed to linux. I greatly enjoy using ROS as it simplifies a lot of things. However I'm not familiar enough with Mac to debug this problem by myself. I have already tried the symlink solution and that still doesn't work for me. Here is what I put into the command line:

sudo ln -s /usr/local/include/freetype2 /usr/local/include/freetype
sudo pip install pil --allow-external pil --allow-unverified pil

and the error that I get:

clang: error: unknown argument: '-mno-fused-madd' [-Wunused-command-line-argument-hard-error-in-future]

clang: note: this will be a hard error (cannot be downgraded to a warning) in the future

error: command 'cc' failed with exit status 1

----------------------------------------
Cleaning up...
Command /usr/bin/python -c "import setuptools, tokenize;__file__='/private/tmp/pip_build_root/pil/setup.py';exec(compile(getattr(tokenize, 'open', open)(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record /tmp/pip-LgDFfc-record/install-record.txt --single-version-externally-managed --compile failed with error code 1 in /private/tmp/pip_build_root/pil
Storing debug log for failure in /Users/chaneyk/Library/Logs/pip.log

Do you guys have any idea where I should start?

edit retag flag offensive close merge delete

Comments

What version of OS X is this on? Did you do `pip install -U pip`? Can you edit your post to include the log (`/Users/chaneyk/Library/Logs/pip.log`)?

demmeln gravatar imagedemmeln ( 2014-03-29 11:09:12 -0600 )edit

I'm currently using OS X Mavericks. Here's a link to the pip log: https://drive.google.com/file/d/0Bxb-MBxS-2X5YV9HZ2pRaFdiSjA/edit?usp=sharing

KennethChaney gravatar imageKennethChaney ( 2014-03-31 04:06:56 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-03-31 04:27:02 -0600

demmeln gravatar image

updated 2014-03-31 04:30:14 -0600

The answers to this stackoverflow question have a lot of suggestions on how to circumvent the problem. It is caused by a change in the latest clang version shipped with that a recent update from apple defaulting to fail on unused arguments: http://stackoverflow.com/questions/22...

EDIT:

TL;DR: One way is:

export CFLAGS=-Qunused-arguments
export CPPFLAGS=-Qunused-arguments
sudo -E pip install ...
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-03-28 10:54:16 -0600

Seen: 1,006 times

Last updated: Mar 31 '14