Ask Your Question
2

SICK lms problem/ A scan was probably missed

asked 2012-09-04 05:25:03 -0500

em gravatar image

updated 2012-09-04 09:44:36 -0500

Hi, I'm having a problem for which I would appreciate any kind of help :)

I'm using ubuntu 10.04, installed ros - by following tutorial, and now i have to use sicklms200, so i installed sicktoolbox - also followed tutorial. When i try to connect to laser, problem which appears is a repeating message - "a scan was probably missed". So i looked for an answer, and got to this recommendation:

Fire up your favorite editor and open this file (your_ros_installation_directory)/ros/diamondback/stacks/sicktoolbox/build/sicktoolbox-1.0/c++/drivers/lms/sicklms-1.0/SickLMS.cc . Go to line 2319.
In this line, add the O_NDELAY flag as shown here:...(source: http://thebattlegoeson.blogspot.com/2011/06/xyz.html)

Problem is that I can't find this file SickLMS.cc, it simply dosen't exist in any of folders :/

I tried reinstalling sicktoolbox and sicktoolbox_wrapper using rosmake (like this:$ rosdep install sicktoolbox_wrapper rviz $ rosmake sicktoolbox_wrapper rviz)

i also find this answer: You'll need to install the laser_drivers stack from source in order to get all of the source files. I'm a total beginner with ros and ubuntu, and probably asking a stupid question, but what does this actually mean? Do i need to add some line in terminal when installing or...??

Again, I'm probably asking stupid questions, but really don't know what else to do or where to find answers so thank you in advance for any help..

edit: I've downloaded and installed the version of ros for ubuntu lucid 10.04 and it's ros fuerte (followed the tutorial http://www.ros.org/wiki/fuerte/Installation/Ubuntu, and installed full version as recommended )

thank you all for answers, I will check out if it works as soon as the SICK is available:)

edit retag flag offensive close merge delete

Comments

1

It's a fine question. But, please edit it so we know what version of ROS you installed and exactly which tutorials you are following.

joq gravatar imagejoq ( 2012-09-04 06:14:36 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2012-09-04 06:17:31 -0500

joq gravatar image

Depending on which ROS version you installed, you may find this tutorial helpful. It explains how to check out ROS source files, which you can edit, build and run.

edit flag offensive delete link more
2

answered 2012-09-04 07:10:39 -0500

Eric Perko gravatar image

Like @joq said, we definitely need to know what version of ROS you are using and which answers you are following (mainly so we we can update those questions with newer answers).

I believe this problem was fixed in the Fuerte release of laser_drivers. See the changelist with link to tickets here: http://ros.org/wiki/laser_drivers/ChangeList/1.6

edit flag offensive delete link more

Comments

It started working, actually I got that message "Data stream started", so thank you :) (I installed it all again, and it just worked.. )

em gravatar imageem ( 2012-09-05 03:41:38 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-09-04 05:25:03 -0500

Seen: 250 times

Last updated: Sep 04 '12