ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Messages being blocked from publishing

asked 2011-11-24 06:07:10 -0600

alfa_80 gravatar image

I am running 2 nodes. One is polar_scan_matcher and the other one is my own node that publishes scan messages. Something is wrong somewhere because when the 2 nodes run at the same time, the publisher of the scan messages is being block as I received an error saying "WARNING: no messages received and simulated time is active. Is /clock being published?" when I run "rostopic echo -c /scan"

As I run "rostopic list", I got these topics:/clock, /goal, /imu, /initialpose, /pose,/pose2D,/rosout, /rosout_agg,/scan,/tf.

What could be the possible culprit? How do I fix it?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2011-11-24 08:05:52 -0600

Chad Rockey gravatar image

updated 2017-11-22 16:59:36 -0600

130s gravatar image

It looks like you've somehow set the "use_sim_time" parameter to true, but you don't have a clock source (ie: rosbag play --clock or some other source, like Gazebo).

Since you're using tf, WallTime isn't an option.

You can check the status of the use_sim_time parameter by using rosparam.

rosparam get use_sim_time

And if it is set somehow, you can reverse it by running:

rosparam set use_sim_time false
edit flag offensive delete link more


Should I run/include this on in the launch file or running as a command? I've tried as a command, still not working..
alfa_80 gravatar image alfa_80  ( 2011-11-24 17:05:26 -0600 )edit
You're right..I've just changed the value in the launch file and that works..Thanks anyway.
alfa_80 gravatar image alfa_80  ( 2011-11-24 18:34:28 -0600 )edit

Just one small addition because it confused one of my contacts: If you use Gazebo this does not apply to you. Gazebo publishes the /clock topic for you.

v4hn gravatar image v4hn  ( 2017-08-29 02:34:01 -0600 )edit

@Chad Rockey I have a question to your recommendation with the flaf of the use_sim_time. In my launch file first I've set this to true, because I get the message about TF_OLD_DATA while playing my recorded bag file. But now I try to use a node and it seems, that the topics is published, but no messages are received (simulated time is active)

Petros ADLATUS gravatar image Petros ADLATUS  ( 2022-04-08 05:30:20 -0600 )edit

answered 2019-08-13 03:38:06 -0600

sandy174 gravatar image

it might be possible that your simulation time is active in the master. you can use the following command in your master: $ rosnode cleanup

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2011-11-24 06:07:10 -0600

Seen: 23,391 times

Last updated: Nov 22 '17