Ask Your Question

Revision history [back]

It looks like you've somehow set the "use_sim_time" parameter to true, but you don't have a clock source (ie: rosbag play --clock or some other source, like Gazebo).

Since you're using tf, WallTime isn't an option.

You can check the status of the use_sim_time parameter by using rosparam.

rosparam get use_sim_time

And if it is set somehow, you can reverse it by running:

rosparam set use_sim_time false

It looks like you've somehow set the "use_sim_time" parameter to true, but you don't have a clock source (ie: rosbag play --clock or some other source, like Gazebo).

Since you're using tf, WallTime isn't an option.

You can check the status of the use_sim_time parameter by using rosparam.

rosparam get use_sim_time

And if it is set somehow, you can reverse it by running:

rosparam set use_sim_time false