Ask Your Question
0

Using OpenNI through Virtual Machine Windows -> Linux Freezes when Xition is plugged in

asked 2012-08-24 05:52:30 -0600

Casey Kuhns gravatar image

updated 2016-10-24 09:03:27 -0600

ngrennan gravatar image

I have been trying to get a Virtual Box machine running on my Windows install to use the Xtion with ROS. Here is my current configuration:

Windows 7 on a Dell Precision with i7 intel Virtual Box 4.1.20 r80170 Ubuntu 12.04 Precise Latest updates on ROS active. Openni version 1.3.2.1-4+precise1

I can get the Xtion to work on my Ubuntu partition but when I try to virtualize on Windows VirtualBox locks up. I cant get anything out of a log file after the crash. My last lines are : USB Operational.

I have installed the USB 2.0 support package for VirtualBox but I still get nothing. The only way to actually kill VirtualBox is to reboot. I can't even terminate the process.

Update: I have found a thread on the Virtual Box forum that hints at a driver support problem https://forums.virtualbox.org/viewtopic.php?f=6&t=43306

Update: I have added a thread on the Virtual Box Community group to see if I can get some answers there. I will be sending in a support ticket to see if I can get any support.

https://forums.virtualbox.org/viewtopic.php?f=6&t=51188&p=234503&hilit=kinect#p234503

Thanks!

edit retag flag offensive close merge delete

Comments

2

"Should I be looking for a different virtual machine? " Well may but maybe it is just better to install a real Linux. You will always have Problems like such which you need to solve if you use a VM.

tlinder gravatar imagetlinder ( 2012-08-24 11:42:12 -0600 )edit

I do have everything working on a linux box out in the lab but our group has constraints on access. Our main workstations are running windows and must continue to do so for administrative reasons. If we could virtualize Ubuntu it would be great but we may have to bug IT for a linux box locally.

Casey Kuhns gravatar imageCasey Kuhns ( 2012-08-27 04:47:34 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2012-08-28 16:53:17 -0600

Kevin gravatar image

Not that this really answers you question directly, but I have never been able to get the Kinect working in a Linux VirtualBox under OSX 10.7 (Lion) as the host. Looking around trying to solve the problem, it appeared as though the USB drivers don't really support the Kinect. I hope you find a solution, but I don't think one exists.

edit flag offensive delete link more

Comments

Same over here. I tried running Ubuntu 10.04 in a virtual machine on Ubuntu 12.04. In my case the Kinect was correctly recognized, but I didn't get any RGB and depth information. Don't know where the problem lies, but in the end I started using a real installation on a separate partition.

bit-pirate gravatar imagebit-pirate ( 2012-09-04 13:47:34 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-08-24 05:52:30 -0600

Seen: 1,853 times

Last updated: Sep 04 '12