Ask Your Question
0

Problem with Gazebo after update.

asked 2012-08-24 03:54:26 -0500

konradb3 gravatar image

updated 2012-08-24 09:49:24 -0500

Hello,

I updated gazebo today (from apt (ubuntu 12.04)) and when i load one of my robots to gazebo all of the robot parts appear in random places.

URDF for my robot is located in : https://github.com/RCPRG-ros-pkg/lwr_robot/tree/electric/lwr_defs

image description

After updating to svn trunk it works much better. But that not solve all of my problems, the second robot link appear translated from its base. It looks like a problem with chaining of fixed links. When i remove the world link and world to world_link joint the offset disappear. image description

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-08-24 06:56:10 -0500

hsu gravatar image

updated 2012-09-07 13:51:38 -0500


update

Ok, there was another issue, thanks konradb3 for the patch! The new release simulator_gazebo 1.6.16 deb is out.


Thanks for posting the model, I was able to test it and found a transform bug when I tried to tweak the urdf2gazebo parser. It's fixed in trunk. I'll make a release (simulator_gazebo 1.6.14) this weekend.

edit flag offensive delete link more

Comments

I checked the svn trunk and it works much better but some problems still remains.

konradb3 gravatar image konradb3  ( 2012-08-24 09:41:26 -0500 )edit

great. can you list out the problems or ticket them on trac (https://bitbucket.org/osrf/gazebo/issues?status=new&status=open)? thanks!

hsu gravatar image hsu  ( 2012-08-24 09:46:25 -0500 )edit

Question updated ...

konradb3 gravatar image konradb3  ( 2012-08-24 09:57:34 -0500 )edit

i'm seeing a similar problem with the Robonaut2 simulator since the update as well.

shart115 gravatar image shart115  ( 2012-08-27 05:37:11 -0500 )edit

Problem also exists with the youBot URDF from https://github.com/youbot/youbot-ros-pkg

rtoris288 gravatar image rtoris288  ( 2012-08-27 06:16:59 -0500 )edit

I'm seeing similar problems as well. Is there documentation somewhere on the best way to checkout simulator_gazebo from svn trunk and replace the existing version I got from apt-get without goofing everything up?

bsatzinger gravatar image bsatzinger  ( 2012-08-27 06:22:49 -0500 )edit

any updates on this fix? It is somewhat unclear whether the trunk fixes this issue (and it doesnt look like 1.6.14 has been released yet...

shart115 gravatar image shart115  ( 2012-08-28 12:27:07 -0500 )edit

just released 1.6.14 yesterday, deb should be out in a day or two. Is the second picture in your original question correct? That's what I see as well. Is there suppose to be a gap between calib_lwr_arm_base_link and lwr_arm_1_link as shown? Also, you mentioned that something else is broken?

hsu gravatar image hsu  ( 2012-08-28 13:02:09 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-08-24 03:54:26 -0500

Seen: 285 times

Last updated: Sep 07 '12