ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

Rviz graphics issues in 20.04/noetic docker

asked 2022-11-17 09:46:19 -0600

kevin_obrien gravatar image

I am trying to set up a docker container for 20.04/noetic development. I notice that whenever I build and run a docker container with 20.04/noetic, I see graphics artifacts on the default Rviz window when I try to manipulate/maximize the window (and more pronounced artifacts the more renderers I add to the Rviz window).

A screenshot is attached to show what I mean by these artifacts (note the black bar towards the bottom of the window that shows up when I try to make the window fullscreen). https://drive.google.com/file/d/1kTfb...

However, if I run the same docker configuration, only with 18.04/melodic inside the container, I don't see these issues.

After building, I run both docker files with the following command:

docker run -it --rm --privileged --net=host --env=NVIDIA_VISIBLE_DEVICES=all --env=NVIDIA_DRIVER_CAPABILITIES=all --env=DISPLAY --env=QT_X11_NO_MITSHM=1 -v /tmp/.X11-unix:/tmp/.X11-unix --runtime=nvidia test_container /bin/bash

Dockerfile 1 (melodic/18.04, Rviz works as expected with no graphics issues):

FROM osrf/ros:melodic-desktop-full 
RUN apt-get update
RUN echo "source /opt/ros/melodic/setup.bash" >> ~/.bash_profile

Dockerfile 2 (noetic/20.04, Rviz has the graphic issues described above):

FROM osrf/ros:noetic-desktop-full 
RUN apt-get update
RUN echo "source /opt/ros/noetic/setup.bash" >> ~/.bash_profile

It's worth noting that I have 20.04/noetic on my host machine, and I don't see these issues when I launch Rviz from host, it's only when I launch it from docker using the 20.04 container (18.04 container also seems to work fine)

Any feedback here would be greatly appreciated, this has been stumping me for a while.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2022-11-17 11:36:42 -0600

duck-development gravatar image

updated 2022-11-17 11:40:18 -0600

I think it is more Ubuntu then Ros problem. The rendering issue comes more from the used Libraries then the Rviz it self.

You may try to deactiva the GPU support. AS described here

http://wiki.ros.org/rviz/Troubleshooting

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2022-11-17 09:46:19 -0600

Seen: 133 times

Last updated: Nov 17 '22