ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

Executing Roslaunch commands inside a running container

asked 2022-10-06 00:32:42 -0500

updated 2022-10-11 02:48:16 -0500

ravijoshi gravatar image

I am trying to run autoware with carla. Autoware is running as a container in linux machine. Now after starting the container, with the following commands

docker run
-it --rm
carla-autoware:latest, the container is up

now I want to launch my launch files to start the auotware nodes using

roslaunch carla_autoware_agent carla_autoware_agent.launch town:=Town04 synchronous_mode:=true

with out entering into the container so I tried to run with docker exec, I am getting the following error

OCI runtime exec failed: exec failed: unable to start container process: exec: "roslaunch": executable file not found in $PATH: unknown

How do I run the roslaunch command in a linux machine without entering into the container either using shell script.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2022-10-12 03:44:46 -0500

goksankobe gravatar image

hi, It seems like roslaunch is not recognized inside the container. Could you verify that ROS is sourced in the docker environment?

As a test, you can manually enter the docker container and type



which roslaunch
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2022-10-06 00:32:42 -0500

Seen: 41 times

Last updated: Oct 12 '22