ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
1

ROS_MASTER_URI address keep changing every time roscore is run

asked 2022-08-24 01:27:15 -0600

vocdex gravatar image

Once in a while, when I run roscore from terminal, it can not connect to its server:

RLException: Unable to contact my own server at [http://192.168.1.123:34759/]. This usually means that the network is not configured properly.

This last part of ROS_MASTER_URI which is 34759 keeps changing when I run roscore multiple times. My bashrc file includes the following at the end:

source /opt/ros/melodic/setup.bash export ROS_MASTER_URI=http://192.168.1.123:11311 export ROS_IP=192.168.1.123

I am a beginner in ROS. I would appreciate your response. Thanks

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2022-08-26 15:45:49 -0600

Edyger gravatar image

I don't know if it will help, but on my laptop where I run roscore, I set this

export ROS_HOSTNAME=myIp
export ROS_MASTER_URI=http://myIp:11311

Maybe try ROS_HOSTNAME instead of ROS_IP.

Maybe you will find your answer on this page http://wiki.ros.org/ROS/NetworkSetup

edit flag offensive delete link more

Question Tools

Stats

Asked: 2022-08-24 01:27:15 -0600

Seen: 43 times

Last updated: Aug 24 '22