Ask Your Question
0

Beginner tutorial - cannot run roscore

asked 2012-07-27 05:29:32 -0600

lizfltn gravatar image

updated 2014-01-28 17:13:10 -0600

ngrennan gravatar image

So I'm incredibly new to ROS (and I'm no Ubuntu master, either) and I've been following the beginner tutorial to the letter. When I try to run roscore (at the appropriate point) I get this print-out:

... logging to /home/liz/.ros/log/336fd2b2-d7fe-11e1-8326-e02a82da7f54/roslaunch-ubuntu-3375.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://ubuntu:52747/
ros_comm version 1.8.10

SUMMARY
========

PARAMETERS
 * /rosdistro
 * /rosversion

NODES

auto-starting new master
Exception AttributeError: AttributeError("'_DummyThread' object has no attribute '_Thread__block'",) in <module 'threading' from '/usr/lib/python2.7/threading.pyc'> ignored
process[master]: started with pid [3391]
ROS_MASTER_URI=http://ubuntu:11311/

setting /run_id to 336fd2b2-d7fe-11e1-8326-e02a82da7f54
Exception AttributeError: AttributeError("'_DummyThread' object has no attribute '_Thread__block'",) in <module 'threading' from '/usr/lib/python2.7/threading.pyc'> ignored
process[rosout-1]: started with pid [3404]
started core service [/rosout]

The system then hangs. Running roswtf gives this:

ERROR The following packages have rpath issues in manifest.xml:
 * beginner_tutorials: found flag "-L/opt/ros/fuerte/lib", but no matching "-Wl,-rpath,/opt/ros/fuerte/lib"
 * std_msgs: found flag "-L/opt/ros/fuerte/lib", but no matching "-Wl,-rpath,/opt/ros/fuerte/lib"
 * roscpp: found flag "-L/opt/ros/fuerte/lib", but no matching "-Wl,-rpath,/opt/ros/fuerte/lib"

I'm running Ubuntu 12.04 (Windows Installer version). I've tried fixing any network configurations (as suggested by the tutorial) and fixing manifest.xml to include the matching -Wl,-rpath,/opt/ros/fuerte/lib". I can't find anything else that fits the problem I'm having, and I'd appreciate any help!

edit retag flag offensive close merge delete

Comments

Could you reformat your question a bit? Please prefix each line you copied from the console with ' ' (four spaces). See also markdown/syntax.

ipso gravatar imageipso ( 2012-07-27 05:37:18 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted
5

answered 2012-07-27 05:55:55 -0600

Lorenz gravatar image

I don't believe that the actually system hangs, roscore is probably running. Open a new console and type rostopic list to verify.

edit flag offensive delete link more
1

answered 2012-07-28 05:12:38 -0600

gpsinghsandhu gravatar image

No answer is accepted so I am posting I have learned that you should always run rxgraph to see whats really going in ROS(that's what I do) In your case if it shows /rosout as a node then your roscore is running.

edit flag offensive delete link more
0

answered 2012-07-27 05:36:07 -0600

PerkinsJames gravatar image

Here is a similar thread that may answer the first part of the error:

http://answers.ros.org/question/34304/exception-attributeerror-when-starting-roscore/

What do you mean your system hangs though? Thats all roscore prints. Have you tried connecting a running ros package to see if it works?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-07-27 05:29:32 -0600

Seen: 2,845 times

Last updated: Jul 28 '12