Ask Your Question
0

"please point me at a wall" Calibration Error [closed]

asked 2012-07-26 22:59:55 -0500

bgagnon gravatar image

updated 2016-10-24 08:34:07 -0500

ngrennan gravatar image

Hello,

I've been able to calibrate my Willow Garage turtlebot just fine up until today. When I powered everything up and tried to calibrate the usual way, I get this error repeating in the terminal where I ran this command:

roslaunch turtlebot_calibration calibrate.launch

Error:

[ERROR] [WallTime: 1343379431.664575] Please point me at a wall.
[ERROR] [WallTime: 1343379431.730219] Please point me at a wall.
[ERROR] [WallTime: 1343379431.794893] Please point me at a wall.
[INFO] [WallTime: 1343379431.848461] Still waiting for scan
[ERROR] [WallTime: 1343379431.863741] Please point me at a wall.
[ERROR] [WallTime: 1343379431.931249] Please point me at a wall.
[ERROR] [WallTime: 1343379431.994555] Please point me at a wall.
[ERROR] [WallTime: 1343379432.062440] Please point me at a wall.
[ERROR] [WallTime: 1343379432.130411] Please point me at a wall.
[INFO] [WallTime: 1343379432.153411] Still waiting for scan
[ERROR] [WallTime: 1343379432.194262] Please point me at a wall.
[ERROR] [WallTime: 1343379432.263563] Please point me at a wall.
[ERROR] [WallTime: 1343379432.330134] Please point me at a wall.
[ERROR] [WallTime: 1343379432.394601] Please point me at a wall.
[INFO] [WallTime: 1343379432.457665] Still waiting for scan
[ERROR] [WallTime: 1343379432.463357] Please point me at a wall.
[ERROR] [WallTime: 1343379432.530496] Please point me at a wall.
[ERROR] [WallTime: 1343379432.594017] Please point me at a wall.
[ERROR] [WallTime: 1343379432.663488] Please point me at a wall.
[ERROR] [WallTime: 1343379432.729796] Please point me at a wall.

This repeats forever and ever. Restarting the turtlebot laptop and Create does nothing. There were no changes made to the turtlebot in any way since last time I used it. Any help would be greatly appreciated.

Blair

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2012-08-03 12:19:33

Comments

Looks, like there is no laser data. Can you check, e.g. in rviz, if you get laser scans, and also if you get kinect data?

dornhege gravatar image dornhege  ( 2012-07-27 02:23:45 -0500 )edit

Yep, rviz works just fine. I get all the Kinect data I could possibly want.

bgagnon gravatar image bgagnon  ( 2012-07-29 22:07:22 -0500 )edit

Do you also get laser data in rviz?

dornhege gravatar image dornhege  ( 2012-07-29 23:47:56 -0500 )edit

Yes

bgagnon gravatar image bgagnon  ( 2012-07-30 00:52:44 -0500 )edit

I had the same problem.

I stopped running rviz, put a turtlebot a little farther from a wall,

relaunched calibrate.launch and it worked well.

Why don't you try the same procedures?

moyashi gravatar image moyashi  ( 2012-07-30 16:27:59 -0500 )edit

So now it starts doing the calibration process, but instead of eventually settling on good calibration values, it always tells me to multiply by ~0.8 to the gyro_scale_correction no matter how many times I run the calibration. The odom_angular_scale_correction seems to be settling ok. Ideas?

bgagnon gravatar image bgagnon  ( 2012-07-30 23:41:42 -0500 )edit

Now, it's settling into a correction scale... I have no idea what happened. Thanks for the help.

bgagnon gravatar image bgagnon  ( 2012-07-31 02:18:22 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-08-03 12:19:23 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Now, it's settling into a correction scale... I have no idea what happened. Thanks for the help. bgagnon (Jul 31 '12)

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-07-26 22:59:55 -0500

Seen: 383 times

Last updated: Aug 03 '12